scripts library load error (macOS)

A plethora of command-line scripts that perform geometric transforms, blurs, sharpens, edging, noise removal, and color manipulations.
Post Reply
ZootZims
Posts: 2
Joined: 2018-12-15T10:44:07-07:00
Authentication code: 1152

scripts library load error (macOS)

Post by ZootZims » 2018-12-15T11:20:28-07:00

Hi,

i read a lot of other threads about a similar subject, but I can't get a script to work.
The installation of ImageMagick works. Convert works without problems.

But when using a script, for example polar I get the error message

Code: Select all

  dyld: Library not loaded: /ImageMagick-7.0.8/lib/libMagickCore-7.Q16HDRI.6.dylib
  Referenced from: $HOME/ImageMagick-7.0.8/bin/convert
  Reason: image not found 
  ...
  
Read and tried the pointers of use, but doesn't work.

Does anyone have a hint?

Code: Select all

convert -version
Version: ImageMagick 7.0.8-9 Q16 x86_64 2018-08-04 https://www.imagemagick.org
Copyright: © 1999-2018 ImageMagick Studio LLC
License: https://www.imagemagick.org/script/license.php
Features: Cipher DPC HDRI 
Delegates (built-in): bzlib freetype jng jpeg lcms png raw tiff webp xml zlib

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2018-12-15T12:20:28-07:00

What was your command line and can you post your image to some free hosting service and put the URL here.

It is possible that script has a bug when using ImageMagick 7. So I would need to test it under your conditions.

Do other of my scripts fail or just this one? If so, which others have you tried.

The error message looks like a configuration issue. How did you install ImageMagick -- from binary, from source, from Homebrew, from MacPorts?

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2018-12-15T12:25:34-07:00

OK. I can get that script to work in ImageMagick 6.9.10.16 but get your same message in IM 7.0.8.16. So I will investigate. There is probably something I need to change to make it compatible with changes in IM 7.

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2018-12-15T12:36:58-07:00

I have fixed the primary issue in the script. But I still get the error message. It appears that my tests for IM 6 vs IM 7 in the script are giving errors when used with IM 7. I have reported the bug on the Bugs form, since it is not an issue with my script.

ZootZims
Posts: 2
Joined: 2018-12-15T10:44:07-07:00
Authentication code: 1152

Re: scripts library load error (macOS)

Post by ZootZims » 2018-12-15T12:49:35-07:00

I just tried to test the script using command portal.sh logo.png logo2.png
It was a binary installation.

Tried port installation on different system and the script works properly, the MacPort Version is 6.9...

Different script stops with same error

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2018-12-15T13:31:32-07:00

Yes, I just figured out what has happened. The ImageMagick format for convert/magick -list configure has changed. So I have to edit every one of my scripts and manually transfer one at a time to my server.

I have fixed polar so it should now run fine. Try downloading again.

If you need any other script and it does not work, let me know and I will modify it for you. Otherwise, I will be changing them slowly as I can.

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2018-12-15T13:33:35-07:00

Note that my polar script is deprecated in favor of the newer and faster -distort polar and -distort depolar. So may just want to use those. See https://imagemagick.org/Usage/distorts/#polar and https://imagemagick.org/Usage/distorts/#depolar

mib
Posts: 6
Joined: 2019-10-14T08:03:23-07:00
Authentication code: 1152

Re: scripts library load error (macOS)

Post by mib » 2019-10-14T08:12:10-07:00

I get the same error on macOS 10.13.6 while try to excute multicrop script.
_____________________________________________
$ multicrop -f 10 -u 2 ABC.tif ABC_a.tif
dyld: Library not loaded: /usr/local/lib/libMagickCore-7.Q16HDRI.6.dylib
Referenced from: /Users/xuzhouya/Downloads/ImageMagick-7.0.8/bin/convert
Reason: image not found
dyld: Library not loaded: /usr/local/lib/libMagickCore-7.Q16HDRI.6.dylib
Referenced from: /Users/xuzhouya/Downloads/ImageMagick-7.0.8/bin/convert
Reason: image not found
/Users/xuzhouya/Downloads/ImageMagick-7.0.8/bin/multicrop: line 427: 919 Abort trap: 6 convert -quiet $dproc "$infile" +repage "$tmpA1"

--- FILE DOES NOT EXIST OR IS NOT AN ORDINARY FILE, NOT READABLE OR HAS ZERO SIZE ---

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2019-10-14T09:40:54-07:00

What is your exact Imagemagick 7 version? How did you install it?

What do you get from

Code: Select all

magick -version
Does your input Tiff have more than one page or layer. The script can only process one page or layer, so use ABC.tif[0]

mib
Posts: 6
Joined: 2019-10-14T08:03:23-07:00
Authentication code: 1152

Re: scripts library load error (macOS)

Post by mib » 2019-10-15T08:00:31-07:00

I tried 3ladies1.jpg on macOS and same result.

Code: Select all

$ magick -version
Version: ImageMagick 7.0.8-69 Q16 x86_64 2019-10-12 https://imagemagick.org
Copyright: © 1999-2019 ImageMagick Studio LLC
License: https://imagemagick.org/script/license.php
Features: Cipher DPC HDRI 
Delegates (built-in): bzlib freetype jng jpeg lcms png raw tiff webp xml zlib

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: scripts library load error (macOS)

Post by fmw42 » 2019-10-15T09:10:44-07:00

What was your exact command line. Before you used -u 2. That requires my script unrotated. Did you install that? IM 7.0.8.69 is not released yet. It could be malfunctioning due to being in development.

I just edited the script to turn off debug mode. Please download it again to be sure you have the most current one. It should say revised 10/15/2019 at the top.

If you have not installed my unrotated script, then try

Code: Select all

multicrop -f 20 -u 1 3ladies1.jpg x.jpg
or

Code: Select all

multicrop -f 20 -u 3 3ladies1.jpg x.jpg

If you have installed it, then try

Code: Select all

multicrop -f 20 -u 2 3ladies1.jpg x.jpg

They both work for me on IM 7.0.8.68 Q16 Mac OSX Sierra

Post Reply