Page 1 of 1

scripts library load error (macOS)

Posted: 2018-12-15T11:20:28-07:00
by ZootZims

i read a lot of other threads about a similar subject, but I can't get a script to work.
The installation of ImageMagick works. Convert works without problems.

But when using a script, for example polar I get the error message

Code: Select all

  dyld: Library not loaded: /ImageMagick-7.0.8/lib/libMagickCore-7.Q16HDRI.6.dylib
  Referenced from: $HOME/ImageMagick-7.0.8/bin/convert
  Reason: image not found 
Read and tried the pointers of use, but doesn't work.

Does anyone have a hint?

Code: Select all

convert -version
Version: ImageMagick 7.0.8-9 Q16 x86_64 2018-08-04
Copyright: © 1999-2018 ImageMagick Studio LLC
Features: Cipher DPC HDRI 
Delegates (built-in): bzlib freetype jng jpeg lcms png raw tiff webp xml zlib

Re: scripts library load error (macOS)

Posted: 2018-12-15T12:20:28-07:00
by fmw42
What was your command line and can you post your image to some free hosting service and put the URL here.

It is possible that script has a bug when using ImageMagick 7. So I would need to test it under your conditions.

Do other of my scripts fail or just this one? If so, which others have you tried.

The error message looks like a configuration issue. How did you install ImageMagick -- from binary, from source, from Homebrew, from MacPorts?

Re: scripts library load error (macOS)

Posted: 2018-12-15T12:25:34-07:00
by fmw42
OK. I can get that script to work in ImageMagick but get your same message in IM So I will investigate. There is probably something I need to change to make it compatible with changes in IM 7.

Re: scripts library load error (macOS)

Posted: 2018-12-15T12:36:58-07:00
by fmw42
I have fixed the primary issue in the script. But I still get the error message. It appears that my tests for IM 6 vs IM 7 in the script are giving errors when used with IM 7. I have reported the bug on the Bugs form, since it is not an issue with my script.

Re: scripts library load error (macOS)

Posted: 2018-12-15T12:49:35-07:00
by ZootZims
I just tried to test the script using command logo.png logo2.png
It was a binary installation.

Tried port installation on different system and the script works properly, the MacPort Version is 6.9...

Different script stops with same error

Re: scripts library load error (macOS)

Posted: 2018-12-15T13:31:32-07:00
by fmw42
Yes, I just figured out what has happened. The ImageMagick format for convert/magick -list configure has changed. So I have to edit every one of my scripts and manually transfer one at a time to my server.

I have fixed polar so it should now run fine. Try downloading again.

If you need any other script and it does not work, let me know and I will modify it for you. Otherwise, I will be changing them slowly as I can.

Re: scripts library load error (macOS)

Posted: 2018-12-15T13:33:35-07:00
by fmw42
Note that my polar script is deprecated in favor of the newer and faster -distort polar and -distort depolar. So may just want to use those. See and