-format "%@" reports a 20 digit long trim width

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
pr3sidentspence
Posts: 27
Joined: 2018-10-31T12:29:16-07:00
Authentication code: 1152

-format "%@" reports a 20 digit long trim width

Post by pr3sidentspence » 2018-11-18T16:53:36-07:00

Windows:
Edition: Windows 10 Home
Version 1809
OS build: 17763.124

IM:
Version: ImageMagick 7.0.8-14 Q16 x64 2018-10-24

Image:
Image

Fuzz values from 57% to 63% in

Code: Select all

-format "%@" info:
all output the same 20 digit number for width. The image is only 4960 pixels wide.
E.g.:

Code: Select all

C:\path>MAGICK TccL95U.jpg -fuzz 57% -format "%@" info:
Outputs:

Code: Select all

18446744073709552000x1895+389+432
Tried on ubuntu (in Windows' subsystem for Linux):
Version: ImageMagick 6.8.9-9 Q16 x86_64 2018-09-28

Works fine:

Code: Select all

0x2326+389+432convert: geometry does not contain image `' @ warning/attribute.c/GetImageBoundingBox/247.

User avatar
fmw42
Posts: 24121
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: -format "%@" reports a 20 digit long trim width

Post by fmw42 » 2018-11-18T17:02:31-07:00

On my Mac OSX Sierra and IM 7.0.8.14 Q16 I get:

Code: Select all

magick TccL95U.jpg -fuzz 57% -format "%@" info:
3111x1897+389+431

which looks fine.

Also using IM 6.9.10.14:

Code: Select all

convert TccL95U.jpg -fuzz 57% -format "%@" info:
3111x1897+389+431

Possible differences could be due to your upload being changed or recompressed by your hosting service.


If I increase the fuzz value, then I get:

Code: Select all

magick TccL95U.jpg -fuzz 75% -format "%@" info:
magick: geometry does not contain image `' @ warning/attribute.c/GetImageBoundingBox/240.
0x0+4960+2465

So perhaps this is a Windows only issue?

pr3sidentspence
Posts: 27
Joined: 2018-10-31T12:29:16-07:00
Authentication code: 1152

Re: -format "%@" reports a 20 digit long trim width

Post by pr3sidentspence » 2018-11-18T17:24:03-07:00

Oh yes, it's significantly different. Sorry about that.

I downloaded from this new link and verified it still happens with this:
https://1drv.ms/u/s!As3ZytCDCPbLj5Vuu8VhCI_JXEwOdw

pr3sidentspence
Posts: 27
Joined: 2018-10-31T12:29:16-07:00
Authentication code: 1152

Re: -format "%@" reports a 20 digit long trim width

Post by pr3sidentspence » 2018-11-18T17:45:25-07:00

If I -chop 1, 2, or 3 pixels off the right, it still does it, but if I chop off 4 pixels it goes back to working fine.

snibgo
Posts: 10945
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: -format "%@" reports a 20 digit long trim width

Post by snibgo » 2018-11-18T18:08:13-07:00

With v6.9.9-50 and v7.0.7-28 on Windows 8.1:

Code: Select all

f:\web\im>%IM%convert TccL95U.jpg -fuzz 57% -format "%@" info:
18446744073709552000x1895+389+432

f:\web\im>%IMG7%magick TccL95U.jpg -fuzz 57% -format "%@" info:
18446744073709552000x1895+389+432

"identify" and exiftool don't report anything strange about the file.

Looks like a bug.
snibgo's IM pages: im.snibgo.com

pr3sidentspence
Posts: 27
Joined: 2018-10-31T12:29:16-07:00
Authentication code: 1152

Re: -format "%@" reports a 20 digit long trim width

Post by pr3sidentspence » 2018-11-18T18:53:41-07:00

Should I report this elsewhere, or is this the spot?

User avatar
GeeMack
Posts: 653
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Re: -format "%@" reports a 20 digit long trim width

Post by GeeMack » 2018-11-18T20:03:16-07:00

I can reproduce this issue with versions 6.9.10-11 Q16 x64 HDRI and 7.0.8-14 Q16 x64 HDRI on Windows 10.

User avatar
fmw42
Posts: 24121
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: -format "%@" reports a 20 digit long trim width

Post by fmw42 » 2018-11-18T20:09:42-07:00

pr3sidentspence wrote:
2018-11-18T18:53:41-07:00
Should I report this elsewhere, or is this the spot?
Here should be sufficient. But if you want, you can create a new issue at https://github.com/ImageMagick/ImageMagick

pr3sidentspence
Posts: 27
Joined: 2018-10-31T12:29:16-07:00
Authentication code: 1152

Re: -format "%@" reports a 20 digit long trim width

Post by pr3sidentspence » 2018-11-19T09:06:48-07:00

I'm running my batch on a larger set of images this morning and have at least one other image that causes this error. I will put all that I find in this shared folder one ondrive https://1drv.ms/f/s!As3ZytCDCPbLj5Vvc7xxM4wXHBrVZA .

pr3sidentspence
Posts: 27
Joined: 2018-10-31T12:29:16-07:00
Authentication code: 1152

Re: -format "%@" reports a 20 digit long trim width

Post by pr3sidentspence » 2018-11-19T09:27:32-07:00


Post Reply