"unknown field with tag 37724 (0x935c) encountered"

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.

"unknown field with tag 37724 (0x935c) encountered"

Postby naoliv » 2010-06-10T06:19:02+00:00

Hi!

We have received a bug report (http://bugs.debian.org/585414) about a conversion from TIFF to XPM.
Testing with the latest beta version (6.6.2-5) it's still possible to see this:

Code: Select all
$ convert BatMon_icon.tif -resize 32x32 batmon.xpm
convert: BatMon_icon.tif: unknown field with tag 37724 (0x935c) encountered. `TIFFReadDirectory' @ warning/tiff.c/TIFFWarnings/704.

The problematic file can be found at http://people.debian.org/~naoliv/misc/i ... n_icon.tif

Is the TIFF file somehow damaged or invalid or it's a problem with ImageMagick, please?

Thank you!
naoliv
 
Posts: 107
Joined: 2007-12-10T18:54:27+00:00
Location: Brazil

Re: "unknown field with tag 37724 (0x935c) encountered"

Postby magick » 2010-06-10T09:29:22+00:00

The exception the user received is informational and is not considered a bug. TIFF allows for tagged metadata. The TIFF specification defines a number of well-known tags. Other proprietary tags are permitted but ignored.
User avatar
magick
Site Admin
 
Posts: 9703
Joined: 2003-05-31T11:32:55+00:00

Re: "unknown field with tag 37724 (0x935c) encountered"

Postby fymus » 2010-09-22T03:14:13+00:00

hi,
i have the same problem with one tif image, and magick++ return an exception by image reading, and my program stops. I use imagemagick6.3.9

how can i handle this problem?

regards
fymus
 

Re: "unknown field with tag 37724 (0x935c) encountered"

Postby fmw42 » 2010-09-22T09:54:54+00:00

User avatar
fmw42
 
Posts: 15026
Joined: 2007-07-02T17:14:51+00:00
Location: Sunnyvale, California, USA

Re: "unknown field with tag 37724 (0x935c) encountered"

Postby fmw42 » 2011-06-21T12:07:18+00:00

inkdroplet wrote:fmw,

Sorry for the thread coming back to life but I did a quick search and was surprised that you thought that this was an issue that we should overlook. At least that is what I am gathering based on the -quiet command? I would like for everything to be in place so I know the program isn't falling apart...



You misunderstand. That was not my intention. I was responding to the original post and was assuming it was a warning and not a crash - sorry - but when one posts a new thread on an old one, things get confusing.

Suggestions to the Poster of the attached thread: Have you tested it using the command line (just a simple convert to another image)? Can you upgrade your IM? Just some suggestions to try to narrow down the issue.
User avatar
fmw42
 
Posts: 15026
Joined: 2007-07-02T17:14:51+00:00
Location: Sunnyvale, California, USA


Return to Bugs

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 4 guests