Cannot install under 64bit windows 7

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
WindedHero

Cannot install under 64bit windows 7

Post by WindedHero » 2010-06-15T14:58:09-07:00

I am trying to install ImageMagick-6.6.2-4-Q16-windows-x64-dll under the current conditions:
ActivePerl 5.10.1 Build 1007 (64-bit)
Windows 7 64bit Ultimate
Apache 2.2.15 64-bit

Install appears successful but does not work with apache. There are no folders or files for magick in perl directory.

Manual PPM install fails:
ppm install failed: The PPD does not provide code to install for this platform

I have tried modifying the Image-Magick.ppd from <ARCHITECTURE NAME="MSWin32-x86-multi-thread-5.10" /> to ... x64..., and it still does not work.
Is there a 64bit dll or PPD for perlmagick? I notice under C:\Program Files\ImageMagick-6.6.2-Q16\PerlMagick\ there is an x86 folder. Why is there no x64?

User avatar
magick
Site Admin
Posts: 10690
Joined: 2003-05-31T11:32:55-07:00

Re: Cannot install under 64bit windows 7

Post by magick » 2010-06-15T15:28:25-07:00

The ImageMagick developers only have access to a 32-bit Windows NT server. As a result, perl is 32-bits although Visual Studio permits us to build the ImageMagick distribution in 64-bits. If some company wants to donate a 64-bit Windows server, we'll build a fully compatible 64-bit ImageMagick distribution with 64-bit perl and 64-bit ImageMagickObject.

WindedHero

Re: Cannot install under 64bit windows 7

Post by WindedHero » 2010-06-15T21:00:15-07:00

Is there a way the general public can compile a 64bit version in the mean time or is the imagemagick project closed-source?

User avatar
magick
Site Admin
Posts: 10690
Joined: 2003-05-31T11:32:55-07:00

Re: Cannot install under 64bit windows 7

Post by magick » 2010-06-16T04:37:17-07:00

ImageMagick is open-source. Anyone can build distributions for the public.

bobinski
Posts: 4
Joined: 2010-08-08T16:17:06-07:00
Authentication code: 8675308

Re: Cannot install under 64bit windows 7

Post by bobinski » 2010-08-13T03:34:47-07:00

I get the impression that there is not a downloadable 64-bit PerlMagick dll and no relevant files for the architecture. The installation fails silently! :(

I don't really know enough to make the correct changes to get a 64 bit Windows 7 version working. Has anyone done it? Can I have a copy? :( :(

I have a working 64bit Perl and a working 64 bit Magick now that version 6.6.3-4 is available. :D I just want a PerlMagick that works with what is probably going to become the most popular platform as many new computers now come in this configuration. :( :( :(

I couln't get the 32bit Perl to work, that seems even harder! :( :( :( :(

benck

Re: Cannot install under 64bit windows 7

Post by benck » 2010-12-07T11:38:57-07:00

magick wrote:ImageMagick is open-source. Anyone can build distributions for the public.
Is there a compiled php_imagick.dll in 64bit now?
I have no idea how to compile 64bit php_imagick.dll using VS 2008.

madjoe
Posts: 2
Joined: 2011-09-29T13:49:09-07:00
Authentication code: 8675308

Re: Cannot install under 64bit windows 7

Post by madjoe » 2011-09-29T14:46:31-07:00

benck wrote:
magick wrote:ImageMagick is open-source. Anyone can build distributions for the public.
Is there a compiled php_imagick.dll in 64bit now?
I have no idea how to compile 64bit php_imagick.dll using VS 2008.
BUMP - It has been almost a year now. So is there a compiled php_imagick.dll in 64bit now?
Thanks!

User avatar
magick
Site Admin
Posts: 10690
Joined: 2003-05-31T11:32:55-07:00

Re: Cannot install under 64bit windows 7

Post by magick » 2011-09-29T17:06:05-07:00

We did not write, nor do we support php_imagick. You might want to locate the php_imagick developers and ask them about 64-bit Imagick under Windows.

madjoe
Posts: 2
Joined: 2011-09-29T13:49:09-07:00
Authentication code: 8675308

Re: Cannot install under 64bit windows 7

Post by madjoe » 2011-09-30T06:32:01-07:00

magick wrote:We did not write, nor do we support php_imagick. You might want to locate the php_imagick developers and ask them about 64-bit Imagick under Windows.
Will do. Thanks for your answer!

euter
Posts: 1
Joined: 2011-10-01T12:27:48-07:00
Authentication code: 8675308

Re: Cannot install under 64bit windows 7

Post by euter » 2011-10-01T12:52:35-07:00

Hello,

i tried to install Magick Perl, that I can use: "use Image::Magick;"

My System is Windows Professional x64 SP1. I nearly tried everything but it didn´t work. Also couldn´t find it in PPM.

Can anyone explain a way to get it work?

tedanoell
Posts: 2
Joined: 2011-10-21T13:28:51-07:00
Authentication code: 8675308

Re: Cannot install under 64bit windows 7

Post by tedanoell » 2011-10-21T13:37:11-07:00

Anything else about the problem? From this info it's hard to tell really...

carabs
Posts: 2
Joined: 2013-02-27T10:10:05-07:00
Authentication code: 6789

Re: Cannot install under 64bit windows 7

Post by carabs » 2013-02-27T10:23:15-07:00

Any updates on this? It is a rather old thread, but I am either doing something wrong with the overall installation of IM and PM, or there is still an issue with the PM installation on Windows7 64bit.

I'll be happy to provide details of my issue later this evening once back to my home computer (where the problem is).

-Jeff

rerdmann
Posts: 2
Joined: 2014-03-28T06:18:28-07:00
Authentication code: 6789

Re: Cannot install under 64bit windows 7

Post by rerdmann » 2017-09-29T13:52:41-07:00

There is obviosly a problem with "ppm install" of Image-Magick.ppd on Windows.
The install-prozess reports only (!):
Unpacking Image-Magick-7.07...done
Updating files in site area...done
But that is not true. Nothing is unpack and C:\Perl64\site\lib is emty!

Then I unpackt and copy the zip-file to C:\Perl64\site\lib manualy.
The ongoing error message is : Can't locate Image/Magick.pm in @INC .....
But now, this is also not true.
C:\Perl64\site\lib\Image\Magick.pm is definitely found. Inside Magick.pm is a problem in Line 72.
Somthing with "bootstrap Image::Magick $VERSION;" is going wrong.

Maybe there is something else going wrong at the instalation-process ... and gaves no message.
Hope someone can fix the intalation-process or describe what to do manually.
Thanks

Post Reply