6.6.3-2-Q16-windows-x64-dll missing wand dll

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
Janzert

6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by Janzert » 2010-08-02T13:32:02-07:00

After using the above windows 64bit dynamic installer attempting to run convert results in the error:
The program cannot start because CORE_RL_wand_.dll is missing from your computer. ...
Looking in the install directory the dll does indeed appear to be missing. Installing the 32bit version does appear to work and install the dll correctly. Unfortunately I need to have a 64bit dll for use with another application.

Janzert

Ked

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by Ked » 2010-08-05T04:09:04-07:00

Same issue for me too.

Using Windows 7 64 bit...

User avatar
magick
Site Admin
Posts: 11040
Joined: 2003-05-31T11:32:55-07:00

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by magick » 2010-08-05T06:56:17-07:00

We will reissue the Windows binaries hopefully within a few days to fix the problem you reported. Thanks.

charlesdeb

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by charlesdeb » 2010-08-07T04:17:56-07:00

I have the same error message. I'm looking forward to 64 bit updates with the missing DLL. I am having a devil of a time getting ImageMagick 32 bit (which installs and runs fine from the command line) to run properly and do resizing within my rails application and am wondering if the 64 bit version might solve my issues.

User avatar
magick
Site Admin
Posts: 11040
Joined: 2003-05-31T11:32:55-07:00

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by magick » 2010-08-07T06:08:18-07:00

We can reproduce the problem you posted and will have a fix within in a few days. Thanks.

Janzert

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by Janzert » 2010-08-12T08:54:36-07:00

Thanks, the 6.6.3-4 installer includes the previously missing dll.

Janzert

bobinski
Posts: 4
Joined: 2010-08-08T16:17:06-07:00
Authentication code: 8675308

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by bobinski » 2010-08-12T17:17:33-07:00

6.6.3.2-4-Q16-windows-x64-dll now install2 a working ImageMagick :D

I also have a 64bit perl version which also works nicely. it's the latest (I think) - version 5.12.1 as you can see from the output of

Code: Select all

perl -v
This is perl 5, version 12, subversion 1 (v5.12.1) built for MSWin32-x64-multi-thread
(with 3 registered patches, see perl -V for more detail)

Copyright 1987-2010, Larry Wall

Binary build 1201 [292674] provided by ActiveState http://www.ActiveState.com
Built May 14 2010 00:22:26
What I really want is to use perlmagick, but even though this seems to be included it's not installing properly, no files are moved to site/... and I have no error messages to point me in the right direction

the relevant library isn't in @INC

I copied the files to what i think is the right place and added the following

Code: Select all

 use lib 'C:/Perl64/site/auto/Image/Magick';
This then fails with
Can't load 'C:/Perl64/site/auto/Image/Magick/Magick.dll' for module Image::Magick:
load_file:%1 is not a valid Win32 application at C:/Perl64/lib/DynaLoader.pm line 201.
I really don't know what's going on, but I need some guidance if i am to make any progress.

Thanks [hopefully]

twidlar
Posts: 1
Joined: 2015-03-02T10:23:25-07:00
Authentication code: 6789

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by twidlar » 2015-03-02T10:51:08-07:00

I installed imagick win7 64bit xampp system following the directions of http://www.zoharbabin.com/5-steps-to-ge ... mpp-1-7-3/

I have XAMPP 1.7.3 with PHP: 5.3.1

httpd.exe Entry Point Not Found -- The procedure entry point MagikGetImageMatte could not be located in the dynamic link library CORE_RL-wand.dll

So I am past the point of CORE_RL-wand.dll missing. Did I get the wrong version? What should I do? (I'm using Eclipse PDT and XDebug but they are not running yet).

Thank you

snibgo
Posts: 11997
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by snibgo » 2015-03-02T11:11:29-07:00

You should check that standalone ImageMagick works:

Code: Select all

convert logo: x.png
convert x.png y.jpg
If that works, than it's a PHP issue that I can't help you with.
snibgo's IM pages: im.snibgo.com

Bonzo
Posts: 2971
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: 6.6.3-2-Q16-windows-x64-dll missing wand dll

Post by Bonzo » 2015-03-02T11:18:58-07:00

The key word here is "imagick" which is a pain to install. You need the correct .dll to go with the correct version of php and Imagemagick compiled by the correct version of virtual something or other.

There are a couple of post about how to install it in the Imagick section but the developers of Imagemagick did not write Imagick or maintain it. Very few people here use it and a lot of the question in the Imagick section are about how to install it. I had it installed once upgraded to Win 7, could not install it again and gave up.

Post Reply