possible bug -fill .. -opaque IM 6.7.8.7 Q16

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 25562
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

possible bug -fill .. -opaque IM 6.7.8.7 Q16

Post by fmw42 » 2012-08-04T11:00:16-07:00

IM 6.7.8.7 Q16 Mac OSX Snow Leopard

I am wondering if the following is a bug or proper behavior?

It seems that one cannot color a binary white image if it is linear rather than sRGB


This works:

convert -size 100x100 xc:white -fill red -opaque white 2tmp1.jpg
Image

These do not:
convert -size 100x100 xc:"gray(255)" -fill red -opaque white 2tmp2.jpg
Image

convert -size 100x100 xc:"gray(255)" -fill red -opaque "gray(255)" 2tmp3.jpg
Image


But this works:

convert -size 100x100 xc:"gray(255)" -set colorspace sRGB -fill red -opaque white 2tmp4.jpg
Image


And so does this:

convert -size 100x100 xc:"gray(255)" -set colorspace RGB -fill red -opaque white 2tmp5.jpg
Image


So it seems to work only if the image and the colors are in the same colorspace. So is this now just a color management issue?

User avatar
magick
Site Admin
Posts: 11064
Joined: 2003-05-31T11:32:55-07:00

Re: possible bug -fill .. -opaque IM 6.7.8.7 Q16

Post by magick » 2012-08-04T14:51:37-07:00

We can reproduce the problem you posted and have a patch. Look for it in ImageMagick 6.7.8-8 Beta by sometime tomorrow. Thanks.

Post Reply