PHP integration CentOS "libWand.so.10" not found

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
JohnSmith
Posts: 11
Joined: 2012-10-01T16:41:10-07:00
Authentication code: 67789

PHP integration CentOS "libWand.so.10" not found

Post by JohnSmith » 2012-10-01T17:12:54-07:00

Frack i spent like 5 hours trying to fix this one issue.

Not a linux guru but i found this work around because i have CentOS (RHEL) and when i install trough YUM it only has up to v6.2.8 that dont have "trimImage" command support.

Also in pecl package imagick was not downloading for some strange issue any version said "its not valid package"...

so i had to find this steps on google http://stackoverflow.com/questions/8664 ... ng-imagick

Code: Select all

  cd /usr/src/
    wget http://acelnmp.googlecode.com/files/imagick-3.0.1.tgz
    tar -xvf imagick-3.0.1.tgz
    cd imagick-3.0.1
    phpize
    ./configure
    make
    make install
then added the extension on php.ini and restarted the server:

Code: Select all

    echo "extension=imagick.so" >> /usr/local/lib/php.ini 
    service httpd restart
Now i uninstalled 6.2.8 and installed 6.7.9 with guide from this page http://www.imagemagick.org/script/insta ... e.php#unix
But php integration broken off.
It was not finding the libWand.so.10
so the fix i could not find is just a symlink inside "/usr/lib" folder command is "ln -s /usr/local/lib/libMagickWand.so.5.0.0 libWand.so.10" followed by "ln -s /usr/local/lib/libMagickWand.so.5.0.0 libMagick.so.10" since that's the second file that was not correct in imagick.so (or without .10 at the end), now it works. In worst case you can set up log the boot errors of php into file and then loop up what's wrong.

Post Reply