6.8.3-8: Invalid gsx command line

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
rwruck
Posts: 7
Joined: 2011-11-09T10:55:59-07:00
Authentication code: 8675308

6.8.3-8: Invalid gsx command line

Post by rwruck » 2013-03-09T15:41:47-07:00

The combination of -dFirstPage..-dLastPage and -dEPSCrop leads to an invalid command line:

"/opt/local/bin/gsx" -q -dQUIET -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 "-sDEVICE=pam" -dTextAlphaBits=4 -dGraphicsAlphaBits=4 "-r305x305" -g2402x1572 -dFirstPage=1 -dLastPage=1-dEPSCrop "-sOutputFile=/var/tmp/magick-46697v1927GFGwnfC" "-f/var/tmp/magick-46697kYzrjTyYZGTY" "-f/var/tmp/magick-46697cQaiU7x8dmiH"
-dvar=name requires name=null, true, or false

This is because there's a space missing after "-dLastPage=%.20g" in coders/ps.c, line 772. Before 6.8.0-5, this was not a big problem because there was no additional option after -dLastPage... but according to the change log, adding -dEPSCrop now is the default.

User avatar
magick
Site Admin
Posts: 11065
Joined: 2003-05-31T11:32:55-07:00

Re: 6.8.3-8: Invalid gsx command line

Post by magick » 2013-03-09T15:52:05-07:00

We can reproduce the problem you posted and have a patch in ImageMagick 6.8.3-9 Beta available by sometime tomorrow. Thanks.

Post Reply