Montage's file name globbing under Windows

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
whugemann
Posts: 295
Joined: 2011-03-28T07:11:31-07:00
Authentication code: 8675308
Location: Münster, Germany 52°N,7.6°E

Montage's file name globbing under Windows

Post by whugemann » 2013-03-10T02:56:57-07:00

The behaviour I reported under viewtopic.php?f=1&t=22935 is probably a new bug, i.e. filename globbing does no longer function if the directory path contains non-ASCII characters, e.g.

montage hähühö\*.jpg -geometry 256x256+8+8 -tile 6x photoindex.jpg

This used to function about two years ago.
Wolfgang Hugemann

User avatar
whugemann
Posts: 295
Joined: 2011-03-28T07:11:31-07:00
Authentication code: 8675308
Location: Münster, Germany 52°N,7.6°E

Re: Montage's file name globbing under Windows

Post by whugemann » 2013-03-16T11:22:49-07:00

I have just digged deeper into the problem and read http://www.imagemagick.org/Usage/files/#read_meta. Something must have changed in recent IM versions, as it does no longer behave that way. Say we have three images in a directory:
i1.jpg
i1.jpg
ä.jpg

Then
identify i*.jpg
will identify the two corresponding files, but
identify ä*.jpg
will not function and neither does it if you put the file name in quotes.

There is also a problem with the (ancient) behaviour as Anthony describes it: If the filename contains spaces, say "hä hü hi.jpg" you will have to put it in quotes anyway, but this would cause IM to take the responsibilty for the expansion into a file list, as far as I understood, and that will probably go wrong.

Addition: I have just tested older IM versions that I still have Windows installation files of and found 6.7.1-4 behaving correctly and 6.7.4-2 behaving the new way, i.e. malfunctioning. Something must have changed inbetween those versions.
Wolfgang Hugemann

User avatar
fmw42
Posts: 25664
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Montage's file name globbing under Windows

Post by fmw42 » 2013-03-16T18:28:59-07:00

I see no clue in the changelog at http://www.imagemagick.org/script/changelog.php

So one of the IM developers will likely have to look into this on Windows.

User avatar
whugemann
Posts: 295
Joined: 2011-03-28T07:11:31-07:00
Authentication code: 8675308
Location: Münster, Germany 52°N,7.6°E

Re: Montage's file name globbing under Windows

Post by whugemann » 2013-03-17T10:25:48-07:00

Well, it says: "Export new Windows binaries" for Version 6.7.4-2 – whatever that specifically means.
The changelog is a good hint. I will have a look at it in the future myself.
Wolfgang Hugemann

User avatar
whugemann
Posts: 295
Joined: 2011-03-28T07:11:31-07:00
Authentication code: 8675308
Location: Münster, Germany 52°N,7.6°E

Re: Montage's file name globbing under Windows

Post by whugemann » 2013-11-15T14:15:06-07:00

I have just checked this again and still found the newest IM build to behave differntly to older versions. I gave in and rewrote my DOS batch file, such that I don't have to incorporate folder names with umlauts. This means that I now make the subfolders the current folder one by one and then generate the index prints in the root directory.

My script is now working fine again, but working on filenames with umlauts is a very common issue in Germany. The same holds for other languages with special characters. So you might give this a second look sometime in the future, as I already nailed down the versions between which this behaviour did change.

I guess this is not only a problem in montage, but also in IM's other command line programs
Wolfgang Hugemann

User avatar
dlemstra
Posts: 1578
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: Montage's file name globbing under Windows

Post by dlemstra » 2013-11-15T15:29:35-07:00

Have you tried 6.8.7-6?
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

User avatar
whugemann
Posts: 295
Joined: 2011-03-28T07:11:31-07:00
Authentication code: 8675308
Location: Münster, Germany 52°N,7.6°E

Re: Montage's file name globbing under Windows

Post by whugemann » 2015-01-01T12:07:52-07:00

I have just had another check on this subject after quite a while –- and found the issue solved in the current IM version. The batch script now works again like it did before the problem occured. No more problems with German umlauts in Montage's filename globbing.
Wolfgang Hugemann

Post Reply