possible bug -compose overlay IM 6.8.5.0 beta Q16 Mac OSX

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
fmw42
Posts: 25549
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

possible bug -compose overlay IM 6.8.5.0 beta Q16 Mac OSX

Post by fmw42 » 2013-04-17T15:17:42-07:00

I am getting vertically striped grayscale results from composing (overlay) a grayscale image with a solid colored image.

This fails with a striped image:

imb convert rose: \
\( -clone 0 -define modulate:colorspace=HSL -modulate 100,0,100 -set colorspace sRGB -write show: \) \
\( -clone 0 -fill "#2bc6ff" -colorize 100% -write show: \) \
\( -clone 1 -clone 2 -compose overlay -composite -write show: \) \
null:


This works fine, by adding -set colorspace RGB before -compose in the 4th line

imb convert rose: \
\( -clone 0 -define modulate:colorspace=HSL -modulate 100,0,100 -set colorspace sRGB -write show: \) \
\( -clone 0 -fill "#2bc6ff" -colorize 100% -write show: \) \
\( -clone 1 -clone 2 -set colorspace RGB -compose overlay -composite -write show: \) \
null:

User avatar
magick
Site Admin
Posts: 11063
Joined: 2003-05-31T11:32:55-07:00

Re: possible bug -compose overlay IM 6.8.5.0 beta Q16 Mac OS

Post by magick » 2013-04-17T17:55:08-07:00

We can reproduce the problem you posted and have a patch in ImageMagick 6.8.5-0 Beta available by sometime tomorrow. Thanks.

Post Reply