[fixed] You break C++ abi....

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
broucaries
Posts: 401
Joined: 2008-12-21T11:51:10-07:00

[fixed] You break C++ abi....

Postby broucaries » 2013-07-14T09:18:58-07:00

Hi,

You have broken a new one the c++ abi
http://upstream-tracker.org/compat_repo ... eport.html

Ok it is sad, and I suppose you could not revert (and this time I do not care because we have not packaged the previous version).

So could you please bump the so number of libmagick++

Remember to bump also the magick++.map version to 2.0

for next major magick++ version coud you please use the trick documented at
http://techbase.kde.org/Policies/Binary ... d_Don.27ts

In order to avoid this kind of problem ?

Bastien
Last edited by broucaries on 2013-07-28T03:34:33-07:00, edited 1 time in total.

broucaries
Posts: 401
Joined: 2008-12-21T11:51:10-07:00

Re: You break C++ abi....

Postby broucaries » 2013-07-14T09:27:54-07:00

Note that I will send a patch to the usual adress. You need to only dump the magick++

User avatar
magick
Site Admin
Posts: 9708
Joined: 2003-05-31T11:32:55-07:00
Contact:

Re: You break C++ abi....

Postby magick » 2013-07-14T12:43:42-07:00

Thanks for the patch. We had a bunch of contributed patches from a user recently and apparently the API breakage missed our radar.


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 6 guests