Convert (version 6.8.6-5) losing ICC

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.

Convert (version 6.8.6-5) losing ICC

Postby sqlgodus » 2013-07-15T11:14:23+00:00

I am converting TIFFs to JPEGs. The TIFFs have an embedded color profile: Adobe RGB
I am using ImageMagick 6.8.6-5 and have tried both the 64bit and 32-bit versions for Windows.

Upon convert, the ICC is dropped from the resulting JPEG. I cannot sort out how to add it back in. I have tried the following:

convert test.tif test.jpg
convert test.tif -profile AdobeRGB1998.icc test.jpg
convert test.tif -profile AdobeRGB1998.icc -profile AdobeRGB1998.icc test.jpg

If I convert between TIFFs, the color profile is retained. If I convert between TIFF and PNG, the color profile is retained.

Is this a bug or am I just not running the command properly?

Thanks.
Andy
sqlgodus
 
Posts: 2
Joined: 2013-07-15T10:51:04+00:00

Re: Convert (version 6.8.6-5) losing ICC

Postby fmw42 » 2013-07-15T11:35:27+00:00

User avatar
fmw42
 
Posts: 15003
Joined: 2007-07-02T17:14:51+00:00
Location: Sunnyvale, California, USA

Re: Convert (version 6.8.6-5) losing ICC

Postby sqlgodus » 2013-07-16T07:42:07+00:00

Thanks for the reference. At the bottom of that thread it says:

"Try 6.8.6-3. That should handle the ICC profile properly."

I am using 6.8.6-5. I will try down-grading to 6.8.6-3 to see if it was fixed and has now reappeared.
sqlgodus
 
Posts: 2
Joined: 2013-07-15T10:51:04+00:00

Re: Convert (version 6.8.6-5) losing ICC

Postby fmw42 » 2013-07-16T09:09:02+00:00

sqlgodus wrote:Thanks for the reference. At the bottom of that thread it says:

"Try 6.8.6-3. That should handle the ICC profile properly."

I am using 6.8.6-5. I will try down-grading to 6.8.6-3 to see if it was fixed and has now reappeared.


If it was fixed in 6.8.6.3 it should be still fixed in 6.8.6.5.

What are the exact conditions that it fails? Can you provide an example image and the exact command you used to make it fail. We can test that in 6.8.6.5.
User avatar
fmw42
 
Posts: 15003
Joined: 2007-07-02T17:14:51+00:00
Location: Sunnyvale, California, USA

Re: Convert (version 6.8.6-5) losing ICC

Postby snibgo » 2013-07-16T09:35:42+00:00

v6.8.6-5 on Windows 7 doesn't seem to embed profiles in jpegs.

Code: Select all
>set I=%IMG6865%

>%I%convert -version
Version: ImageMagick 6.8.6-4 2013-07-08 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2013 ImageMagick Studio LLC
Features: DPC OpenMP
Delegates: bzlib djvu fftw fontconfig freetype jng jp2 jpeg lcms lzma openexr pa
ngo png ps tiff x xml zlib

>%I%convert xc: -profile AdobeRGB1998.icc j.png
>%I%convert xc: -profile AdobeRGB1998.icc j.tif
>%I%convert xc: -profile AdobeRGB1998.icc j.jpg

>%I%identify -verbose j.png |cgrep /i- /sprofile /g
Search for {*profile*}
Searched 75 records in 1 file.
  Output 2 records from 1 file.

  Profiles:
    Profile-icc: 560 bytes

>%I%identify -verbose j.tif |cgrep /i- /sprofile /g
Search for {*profile*}
Searched 66 records in 1 file.
  Output 2 records from 1 file.

  Profiles:
    Profile-icc: 560 bytes

>%I%identify -verbose j.jpg |cgrep /i- /sprofile /g
Search for {*profile*}
Searched 316 records in 1 file.
  Output 0 records from 0 files.
snibgo's IM pages: im.snibgo.com
snibgo
 
Posts: 3953
Joined: 2010-01-23T23:01:33+00:00

Re: Convert (version 6.8.6-5) losing ICC

Postby fmw42 » 2013-07-16T11:22:59+00:00

I can confirm that also on Mac OSX

convert zelda3.jpg -profile /Users/fred/images/profiles/sRGB.icc zelda3p.jpg

result shows no Profiles associated with the output
User avatar
fmw42
 
Posts: 15003
Joined: 2007-07-02T17:14:51+00:00
Location: Sunnyvale, California, USA

Re: Convert (version 6.8.6-5) losing ICC

Postby magick » 2013-07-16T13:11:39+00:00

We can reproduce the problem you posted and have a patch in ImageMagick 6.8.6-6 Beta available by sometime tomorrow. Thanks.
User avatar
magick
Site Admin
 
Posts: 9696
Joined: 2003-05-31T11:32:55+00:00


Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests