ImageMagick RPM has unresolvable dependencies

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
MrBluewoods
Posts: 6
Joined: 2016-08-22T12:55:51-07:00
Authentication code: 1151

ImageMagick RPM has unresolvable dependencies

Post by MrBluewoods » 2016-08-22T20:30:15-07:00

Hello,

I am trying to install ImageMagick 7 on CentOS 7. So far, CentOS's official repositories only have ImageMagick 6. Therefore, I tried to install the RPM on the ImageMagick download page. However, it seems to be missing dependencies on ImageMagick libraries:

Code: Select all

[username@SIMC7 Downloads]$ sudo rpm -i ImageMagick-7.0.2-9.x86_64.rpm 
error: Failed dependencies:
	ImageMagick-libs = 7.0.2-9 is needed by ImageMagick-7.0.2-9.x86_64
	libMagickCore-7.Q16HDRI.so.0()(64bit) is needed by ImageMagick-7.0.2-9.x86_64
	libMagickWand-7.Q16HDRI.so.0()(64bit) is needed by ImageMagick-7.0.2-9.x86_64
	libMagickWand-7.Q16HDRI.so.0(VERS_1.0)(64bit) is needed by ImageMagick-7.0.2-9.x86_64
Unless I'm mistaken, since those are ImageMagick libraries, there is no way to obtain them except from ImageMagick, and hence, they should be included in the package or downloadable from the website.

Thank you.

Post Reply