Possible Bug. -color-matrix doesn't work in mogrify

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
GiantCowFilms
Posts: 17
Joined: 2017-02-28T22:08:29-07:00
Authentication code: 1151

Possible Bug. -color-matrix doesn't work in mogrify

Post by GiantCowFilms » 2017-04-06T18:03:29-07:00

Produces expected results

Code: Select all

magick convert "a.tif" -color-matrix "3x3: 0.84660338, 0.28883142, -0.12901039, -0.022563746, 1.0869868,  0.015131218, -0.026749236, -0.046278112, 1.199862" "b.tif"
Doesn't produce expected results

Code: Select all

magick mogrify "a.tif" -color-matrix "3x3: 0.84660338, 0.28883142, -0.12901039, -0.022563746, 1.0869868,  0.015131218, -0.026749236, -0.046278112, 1.199862"
My image editor (Blender 3D in this case - yeah I know whats and odd choice, but I know what I'm doing) says #QNAN for the values, and windows photos viewer gives me an all black image. The image is a normal size (around 21 MP) 32 bit tiff that contains relatively low values, but does have a few bright areas, so all black is not the expected result.

User avatar
fmw42
Posts: 25668
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Possible Bug. -color-matrix doesn't work in mogrify

Post by fmw42 » 2017-04-06T18:30:08-07:00

try placing the image at the end of the command, especially for IM 7
magick mogrify -color-matrix "3x3: 0.84660338, 0.28883142, -0.12901039, -0.022563746, 1.0869868, 0.015131218, -0.026749236, -0.046278112, 1.199862" "a.tif"

Post Reply