unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
eprocessing
Posts: 2
Joined: 2017-09-20T18:49:46-07:00
Authentication code: 1151

unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

Post by eprocessing » 2017-09-20T19:13:59-07:00

After upgrading from ImageMagick version 7.0.6-9 Q16 to version 7.0.7-1 Q16, I received the following errors:

20170920 204421 00000 [42364]:103 imageSize: Error
20170920 204421 00000 [42364]:104 identify: unable to load module 'C:\Program Files\ImageMagick-7.0.7-Q16\modules\coders\IM_MOD_RL_PNG_.dll': The specified module could not be found.
20170920 204421 00000 [42364]:105 @ error/module.c/OpenModule/1270.
20170920 204421 00000 [42364]:106 identify: no decode delegate for this image format `PNG' @ error/constitute.c/ReadImage/509.
20170920 204421 0215928 [42364]:107 storeImage : Invalid image or unusable size

This also happens with version 7.0.7-3 Q16. I reverted back to version 7.0.6-9 Q16 and the errors stopped. What could have changed in ImageMagick to cause this?

User avatar
dlemstra
Posts: 1386
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

Post by dlemstra » 2017-09-20T22:40:23-07:00

Did you install the VS2013 redistributable?
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

eprocessing
Posts: 2
Joined: 2017-09-20T18:49:46-07:00
Authentication code: 1151

Re: unable to load module IM_MOD_RL_PNG_.dll in version 7.0.7

Post by eprocessing » 2017-09-21T06:09:00-07:00

Yes, the x64 version is installed.

Post Reply