Problem with Emacs introduced between 6.9.9-13 and 6.9.9-14

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
karvus
Posts: 3
Joined: 2017-09-29T06:59:08-07:00
Authentication code: 1151

Problem with Emacs introduced between 6.9.9-13 and 6.9.9-14

Post by karvus » 2017-09-29T07:39:17-07:00

When upgrading from 6.9.9-13 to 6.9.9-14 or 6.9.9-15 a regression seems to have been introduced, breaking interaction with Emacs (25.3.1) in some way.

To reproduce:
  • launch emacs
  • open a .png file
  • M-x image-transform-reset
which should yield the error to *Messages*

Code: Select all

ImageMagick error: no decode delegate for this image format `PNG' @ error/constitute.c/ReadImage/504
Note that libpng is installed, and that PNG is listed as a delegate as shown below, and that conversion works from the command line.

This bug has been reported earlier on the Arch Linux bugtracker: https://bugs.archlinux.org/task/55690

More information about running software:

Code: Select all

$ convert --version | head 1
Version: ImageMagick 6.9.9-15 Q16 x86_64 2017-09-23 http://www.imagemagick.org

$ convert -list configure | grep DEL
DELEGATES      bzlib mpeg fontconfig freetype gslib jng jpeg lcms lqr lzma openexr openjp2 pango png ps raqm raw rsvg tiff webp wmf x xml zlib
$ uname -a
Linux dora 4.12.13-1-ARCH #1 SMP PREEMPT Fri Sep 15 06:36:43 UTC 2017 x86_64 GNU/Linux

$ emacs --version | head -1
GNU Emacs 25.3.1
Cheers

karvus
Posts: 3
Joined: 2017-09-29T06:59:08-07:00
Authentication code: 1151

Re: Problem with Emacs introduced between 6.9.9-13 and 6.9.9-14

Post by karvus » 2017-10-08T01:31:06-07:00

Any suggestions how I can dig out some more relevant information about this?

Cheers, Thomas

User avatar
dlemstra
Posts: 1383
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: Problem with Emacs introduced between 6.9.9-13 and 6.9.9-14

Post by dlemstra » 2017-10-08T02:32:40-07:00

I think your issue is already solved in the latest version of ImageMagick. I think it is related to this issue: https://github.com/ImageMagick/ImageMagick/issues/825
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

karvus
Posts: 3
Joined: 2017-09-29T06:59:08-07:00
Authentication code: 1151

Re: Problem with Emacs introduced between 6.9.9-13 and 6.9.9-14

Post by karvus » 2017-10-08T07:45:52-07:00

True! Upgrading to 6.9.19 from 6.9.13 fixed the problem for me.

Cheers

Post Reply