Error reading from pipe with IM 7.0.7-17

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GeeMack
Posts: 613
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Error reading from pipe with IM 7.0.7-17

Post by GeeMack » 2017-12-27T21:22:24-07:00

I've encountered an issue with recently released version IM 7.0.7-17 Q16 x64 HDRI on Windows 10 64. If I run this command...

Code: Select all

magick logo: MIFF:- | magick - test.png
I get this error...

Code: Select all

magick: improper image header `-' @ error/miff.c/ReadMIFFImage/1092.
I can avoid the error by specifying the MIFF format when reading the data from the pipe if I modify the command like this...

Code: Select all

magick logo: MIFF:- | magick MIFF:- test.png
But using "MIFF:-" to read the output of the pipe was not necessary in previous versions.

User avatar
fmw42
Posts: 23678
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Error reading from pipe with IM 7.0.7-17

Post by fmw42 » 2017-12-27T21:47:40-07:00

This works fine for me on IM 7.0.7.17 Q16 HDRI Mac OSX Sierra

Code: Select all

magick logo: MIFF:- | magick - test.png

User avatar
magick
Site Admin
Posts: 10835
Joined: 2003-05-31T11:32:55-07:00

Re: Error reading from pipe with IM 7.0.7-17

Post by magick » 2017-12-28T10:19:49-07:00

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ https://www.imagemagick.org/download/beta/ by sometime tomorrow.

Post Reply