Possible problem with TIFF:- IM7.0.7-21 and Windows

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GeeMack
Posts: 531
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Possible problem with TIFF:- IM7.0.7-21 and Windows

Post by GeeMack » 2018-01-19T20:25:58-07:00

From a discussion in this thread, using IM 7.0.7-21 Q16 HDRI on Windows 10. This command results in no output at all...

Code: Select all

magick logo: TIFF:- | magick identify -verbose -
It displays all the verbose information if I output the command on the left of the pipe in formats like "JPEG:-" or "PNG:-"

If I try to output that "TIFF:-" through the pipe into another "magick" convert command it results in an error.

Code: Select all

magick logo: TIFF:- | magick - test.png

magick: no images for write '-write' 'test.png' at CLI arg 2 @ error/operation.c/CLINoImageOperator/4789.
It looks like the "TIFF:-" isn't producing any output at all. This appears to be a bug.

User avatar
magick
Site Admin
Posts: 10756
Joined: 2003-05-31T11:32:55-07:00

Re: Possible problem with TIFF:- IM7.0.7-21 and Windows

Post by magick » 2018-01-20T00:10:00-07:00

We believe the problem you reported is fixed in 7.0.7-22 Beta. We should have a release within a week.

User avatar
GeeMack
Posts: 531
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Re: Possible problem with TIFF:- IM7.0.7-21 and Windows

Post by GeeMack » 2018-01-22T19:12:57-07:00

This issue still exists in ImageMagick 7.0.7-22 Q16 x64 HDRI on Windows 10.

Post Reply