Imagick EPT Delegate Support, Compiling from Source

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
NateAGeek
Posts: 3
Joined: 2018-02-23T11:55:24-07:00
Authentication code: 1152

Imagick EPT Delegate Support, Compiling from Source

Post by NateAGeek » 2018-02-23T16:59:28-07:00

Hello,

I'm currently trying to compile ImageMagick from source statically. I keep getting issues with EPT Delegate not being supported with Imagick PHP extension. I've compiled the ImageMagick source with gslib, 9.10v. Is there something extra that needs to be provided to compile ImageMagick source to support EPT?

Thank you,
Nate

Compiling Config:

Code: Select all

./configure --with-rsvg --with-gslib --with-png --with-tiff CFLAGS='-static -fPIC' --prefix=`pwd`/usr/local

User avatar
fmw42
Posts: 24475
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Imagick EPT Delegate Support, Compiling from Source

Post by fmw42 » 2018-02-23T17:43:25-07:00

It requires you to have actually installed Ghostscript onto your system where ImageMagick can find it. Be sure there are no install errors for Ghostscript.

NateAGeek
Posts: 3
Joined: 2018-02-23T11:55:24-07:00
Authentication code: 1152

Re: Imagick EPT Delegate Support, Compiling from Source

Post by NateAGeek » 2018-02-24T23:59:17-07:00

fmw42 wrote:
2018-02-23T17:43:25-07:00
It requires you to have actually installed Ghostscript onto your system where ImageMagick can find it. Be sure there are no install errors for Ghostscript.
Ok, is there a minimal version for GhostScripts? Also, like I mentioned earlier we are trying to statically link the library, is that an issue since we do not want it to dynamically link.

Thank you,
Nate

User avatar
fmw42
Posts: 24475
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Imagick EPT Delegate Support, Compiling from Source

Post by fmw42 » 2018-02-25T12:20:40-07:00

Sorry, I do not know about compiling the libraries. One of the developers or more knowledgeable users may have to help you on that account. But I would suggest that you first resolve the issue with getting Ghostscript installed.

NateAGeek
Posts: 3
Joined: 2018-02-23T11:55:24-07:00
Authentication code: 1152

Re: Imagick EPT Delegate Support, Compiling from Source

Post by NateAGeek » 2018-02-25T16:03:48-07:00

Well, that is the issue, I do have GhostScript 9.10 installed on the system, libs, includes, and all. I just want to know specifications on why PSD, AI, and other adobe files are support, however, yet only EPT is not supported. How can I get EPT to work? It has been driving me nuts. haha

User avatar
fmw42
Posts: 24475
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Imagick EPT Delegate Support, Compiling from Source

Post by fmw42 » 2018-02-25T16:39:16-07:00

Are you trying to read or write to EPT? What was your command line? What is your exact version of Imagemagicvk? Have you tried updating Ghostscript. I think it is currently at 9.22. When you do

Code: Select all

convert -version
or

Code: Select all

convert -list configure
Do you see gs or gslib in the list of delegates.

Can you convert it in the command line rather than Imagick?

Sometimes, Imagick cannot find ghostscript. In that case, you need to modify your delegates.xml file to put the full path to ghostscript where it shows gs for the command. See viewtopic.php?f=1&t=31644&p=144301&hili ... pt#p144307

Post Reply