IM6.9.9, IM7.0.7, and Windows 10 clipboard:

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GeeMack
Posts: 647
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

IM6.9.9, IM7.0.7, and Windows 10 clipboard:

Post by GeeMack » 2018-04-09T12:08:03-07:00

Using ImageMagick versions 6.9.9-40 Q16 HDRI or 7.0.7-28 Q16 HDRI from the command line on Windows 10 64.

I create a grayscale image with this command...

Code: Select all

magick wizard: -colorspace gray wiz1.png
I open the resulting "wiz1.png" to view in IrfanView, Photoshop, or Photoshop Elements.

In any of those programs I copy the image to the Windows clipboard with "edit > copy" or "ctrl-C", etc.

Then back to the command line window and I run this command...

Code: Select all

magick clipboard: wiz2.png
That reads the Windows clipboard and writes it back to file "wiz2.png". The resulting image has rolled several pixels to the right, and rolled up a couple pixels, too.

This seems to occur opening any image (1) modified with IM's "-colorspace gray", (2) saved to a file, (3) opened in common editing programs, (4) copied to the Windows clipboard, (5) then read back into an IM command and saved in common formats like JPG, TIF, PNG.

The results appear identical using IM7 "magick" or IM6 "convert".

The problem does not occur when copying the image to the clipboard from a Firefox browser window, from ImageJ, or from IM's "imdisplay.exe".

This is "wiz2.png"...

Image

Post Reply