Problem reading memory register "mpr:test[0,0,0,0]"...

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GeeMack
Posts: 612
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Problem reading memory register "mpr:test[0,0,0,0]"...

Post by GeeMack » 2018-08-07T12:07:11-07:00

Running ImageMagick 7.0.8-9 Q16 x64 HDRI from a Windows 10 command line. This command generates four output images ("info:" in this example), all copies of the first index "0" in the memory register "mpr:test"...

Code: Select all

magick rose: granite: -write mpr:test -delete 0--1 mpr:test[0,0,0,0] info:
... as shown in the "info:" output.

Code: Select all

mpr:test[0,0,0,0][0] PNM 70x46 70x46+0+0 8-bit sRGB 0.016u 0:00.016
mpr:test[0,0,0,0][1] PNM 70x46 70x46+0+0 8-bit sRGB 0.016u 0:00.016
mpr:test[0,0,0,0][2] PNM 70x46 70x46+0+0 8-bit sRGB 0.016u 0:00.016
mpr:test[0,0,0,0][3] PNM 70x46 70x46+0+0 8-bit sRGB 0.016u 0:00.016
However, when there is only one image in the "mpr:test" register as with this command...

Code: Select all

magick rose: -write mpr:test -delete 0--1 mpr:test[0,0,0,0] info:
... the "info: shows only a single output image even though I asked for four copies of it with "mpr:test[0,0,0,0]". The "info:" is this...

Code: Select all

mpr:test[0,0,0,0] PNM 70x46 70x46+0+0 8-bit sRGB 0.000u 0:00.000
I would expect the command to return four images, but it only returns one. Is there a reason for this, or is it a bug?

User avatar
magick
Site Admin
Posts: 10833
Joined: 2003-05-31T11:32:55-07:00

Re: Problem reading memory register "mpr:test[0,0,0,0]"...

Post by magick » 2018-08-07T17:37:54-07:00

Thanks for the problem report. We can reproduce it and will have a patch to fix it in GIT master branch @ https://github.com/ImageMagick/ImageMagick later today. The patch will be available in the beta releases of ImageMagick @ https://www.imagemagick.org/download/beta/ by sometime tomorrow.

User avatar
GeeMack
Posts: 612
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

Re: Problem reading memory register "mpr:test[0,0,0,0]"...

Post by GeeMack » 2018-08-14T15:09:44-07:00

This issue appears to be resolved in version 7.0.8-10. Thanks!

Post Reply