pkgconfig and C++ API changes

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
coder@ervnet.de
Posts: 1
Joined: 2018-08-20T11:58:02-07:00
Authentication code: 1152

pkgconfig and C++ API changes

Post by coder@ervnet.de » 2018-08-20T12:17:25-07:00

As shown in https://bugs.gentoo.org/663468 and others for Imagemagick7 and linking apps, there are issues related to pkgconfig, and others to the C++ API Changes. Especilally inkscape, which is animportant piece of OS Software.

1. Inkscape didn't recognize IM7 because it looks for ImageMagick++ in pkgconfig, not for Magick++, and that isn't found.

If I generate a symlink the Inkscape set up finds ImageMagick++ but it uses the removed deprecated functions and errors.

To figure out a solution I'd like to know:

1. The pkgconfig entries and links through the V6.9 to recent history, because then the configure checks can be adjusted.

2. The C++ API removements an there replacements to obtain patches for the failing apps.

Where can I find this information? (without parsing every release)

Ervin
coder.ervnet.de

Post Reply