IM7.0.8-24 - Invalid argument for option '-transparent-color'

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
User avatar
GeeMack
Posts: 664
Joined: 2015-12-01T22:09:46-07:00
Authentication code: 1151
Location: Central Illinois, USA

IM7.0.8-24 - Invalid argument for option '-transparent-color'

Post by GeeMack » 2019-01-18T09:54:46-07:00

Using ImageMagick 7.0.8-24 Q16 x64 HDRI on Windows 10. When running this command...

Code: Select all

magick logo: -transparent-color black info:
I get this error...

Code: Select all

magick: invalid argument for option '-transparent-color' 'black' at CLI arg 2 @error/operation.c/CLISettingOptionInfo/1469.
This occurs when using any color as the argument, and when using any method of color description. All these produce the same error...

Code: Select all

magick logo: -transparent-color black info:

magick logo: -transparent-color #FF00CC info:

magick logo: -transparent-color srgb(23,123,223) info:
The error does not occur when running the commands using "convert" with version 6.9.10-11.

User avatar
fmw42
Posts: 24465
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: IM7.0.8-24 - Invalid argument for option '-transparent-color'

Post by fmw42 » 2019-01-18T10:21:48-07:00

try

Code: Select all

magick logo: -set -transparent-color black info:

Post Reply