tiff:has-layers no longer works when [0] is added.

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
246246
Posts: 178
Joined: 2015-07-06T07:38:22-07:00
Authentication code: 1151

tiff:has-layers no longer works when [0] is added.

Post by 246246 » 2019-05-01T08:03:03-07:00

I think it happened every layered tiff, but the file has taken from https://www.imagemagick.org/discourse-s ... =1&t=35942

Code: Select all

$ magick identify -format '%[tiff:has-layers]\n' 10212_transparent_with_layers.tif[0]
identify: Incompatible type for "RichTIFFIPTC"; tag ignored. `TIFFFetchNormalTag' @ warning/tiff.c/TIFFWarnings/995.
identify: incorrect count for field "DateTimeOriginal" (21, expecting 20); tag trimmed. `10212_transparent_with_layers.tif' @ warning/tiff.c/TIFFWarnings/995.
identify: ASCII value for tag "DateTimeOriginal" does not end in null byte. `TIFFFetchNormalTag' @ warning/tiff.c/TIFFWarnings/995.
identify: unknown image property "%[tiff:has-layers]" @ warning/property.c/InterpretImageProperties/3990.

$ magick identify -quiet -format '%[tiff:has-layers]\n' 10212_transparent_with_layers.tif[0]

It now outputs warning unknown image property "%[tiff:has-layers]" , but it had worked at 6.9.1-0 and output true.
See https://www.imagemagick.org/discourse-s ... 45#p123969

Code: Select all

$ magick -version
Version: ImageMagick 7.0.8-42 Q16 x86_64 2019-04-24 https://imagemagick.org
Copyright: © 1999-2019 ImageMagick Studio LLC
License: https://imagemagick.org/script/license.php
Features: Cipher DPC HDRI Modules OpenMP 
Delegates (built-in): bzlib freetype heic jng jp2 jpeg lcms ltdl lzma openexr png tiff webp xml zlib

Post Reply