Possible partial use of pixels while creating signatures

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
mbrijun
Posts: 10
Joined: 2019-05-05T10:06:02-07:00
Authentication code: 1152

Possible partial use of pixels while creating signatures

Post by mbrijun » 2019-05-06T01:52:37-07:00

Not sure if this is a cosmetic issue or a bug. I have observed it in both 6.9.10-44 and 7.0.8-44 on 64-bit Windows 10.

When using "-monitor" with "identify", it seems to omit the last row of pixels from the progress. In my case it seems to read 2013 out of 2014 rows of pixels, as can be seen in the snippet below.

Code: Select all

>identify -version
Version: ImageMagick 6.9.10-44 Q16 x64 2019-05-04 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2015 ImageMagick Studio LLC
License: http://www.imagemagick.org/script/license.php
Visual C++: 180040629
Features: Cipher DPC Modules OpenMP(2.0)
Delegates (built-in): bzlib cairo flif freetype gslib heic jng jp2 jpeg lcms lqr lzma openexr pangocairo png ps raw rsvg tiff webp xml zlib

>identify -monitor -format %# u:\test\test.NEF
load image[u:\test\test.NEF]: 2013 of 2014, 100% complete
040da5598d899f0fc9ea8527925602de87d38d97061cddb25134cf6f358cfc2a

snibgo
Posts: 11801
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Possible partial use of pixels while creating signatures

Post by snibgo » 2019-05-06T03:08:57-07:00

"-monitor" gives the row number, from 0, and the number of rows. When you have 2014 rows, the last is numbered 2013.
snibgo's IM pages: im.snibgo.com

Post Reply