MagickStudio - error

Use this forum for comments, suggestions or problems related to the online ImageMagick Studio web interface @ https://imagemagick.org/MagickStudio.
Post Reply
User avatar
magick
Site Admin
Posts: 10924
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-10-12T16:40:24-07:00

We do not include fonts with the distribution because many fonts have copyright restrictions. You can add whatever fonts you have in the fonts directory and be sure to update the type.xml configuration file. If you have no fonts you can try changing the default font in the script from Arial to Helvetica.

undisclosed

Re:

Post by undisclosed » 2007-02-23T01:26:28-07:00

magick wrote: We do not include fonts with the distribution because many fonts have copyright restrictions. You can add whatever fonts you have in the fonts directory and be sure to update the type.xml configuration file. If you have no fonts you can try changing the default font in the script from Arial to Helvetica.


Greetings,
I'm experiencing the same problem. Unlike the original poster, I'm running
it on one of our own servers and I have some 1.5 meg of TrueType
fonts in the /MagickStudio/fonts directory - arial in included . ;) But
inspite of it I recieve the same message. The fonts directory id owned by
the owner/group the web server runs under, and all fonts under the directory
are owned by the group the web server runs under and readable by all.
I have no idea where to find the type.xml file you
mention, as it didn't come in the MagickStudio archive. But I have tried
every incarnation I can think of for MagickStudio.cgi and MagickStudio.pm.
Those attempted follow:
As supplied in it's default and currently accurate form

Code: Select all

$ENV{MAGICK_FONT_PATH}=$DocumentRoot . $DocumentDirectory . "/fonts";
OK. That didn't work. Let's try hanging a slash on the end of fonts:

Code: Select all

$ENV{MAGICK_FONT_PATH}=$DocumentRoot . $DocumentDirectory . "/fonts/";
Nope. That didn't work either. Lets see if it's a matter of case SensItivitY:
(from MagickStudio.pm)

Code: Select all

our $DefaultFont = "arial";
(previously Arial)
Hmm... That didn't work either. Maybe hanging the ttf extension on it:

Code: Select all

our $DefaultFont = "arial.ttf";
Nope. No good either.
OK. How 'bout using an absolute path in MagickStudio.cgi:

Code: Select all

$ENV{MAGICK_FONT_PATH}='/absolute/path/to/MagickStudio/fonts';
Nope. No good either.
One last try. Let's try hanging a slash off the end of the fonts dir:

Code: Select all

$ENV{MAGICK_FONT_PATH}='/absolute/path/to/MagickStudio/fonts/';
OK. That's no good either. Must be that this fonts business is something that's
planned but not yet available yet... or is it?

Thank you for all your time and consideration in this matter.

--Chris

P.S. I am running this on a UNIX (BSD) box. It is the most recent version
of everything and includes ImageMagick with every option/ extension available,
including perlmagick. ImageMagick itself works flawlessly, as does the
Apache server MagickStudio is running on.

Thanks again.

User avatar
magick
Site Admin
Posts: 10924
Joined: 2003-05-31T11:32:55-07:00

Re: MagickStudio - error

Post by magick » 2007-02-23T12:14:11-07:00

Grab MagickStudio 1.9.1 tommorrow. We added a script in the fonts directory that will generate a proper type.xml font configuration file.

undisclosed

Re: MagickStudio - error

Post by undisclosed » 2007-02-23T12:37:29-07:00

magick wrote: Grab MagickStudio 1.9.1 tommorrow. We added a script in the fonts directory that will generate a proper type.xml font configuration file.


WOOHOO!
That's excellent news.

Thank you very much for such a fast and helpful reply!

Best wishes to you.
Chris out...

Post Reply