SHA2.pm problems :(

Use this forum for comments, suggestions or problems related to the online ImageMagick Studio web interface @ https://imagemagick.org/MagickStudio.
Post Reply
I-B

SHA2.pm problems :(

Post by I-B » 2007-09-18T15:43:27-07:00

Regard 8)
I Install MagickStudio-1.9.1, but module SHA2.pm did not turn out to be on hosting
Can't locate Digest/SHA2.pm in @INC (@INC contains:
then I has changed in file MagickStudio.cgi SHA2 on SHA1 8)
and has earned, but now I get mistake
Exception 445: unable to persist pixel cache `MagickStudio.mpc':
and I little upset
$path/MagickStudio.mpc

tell little about SHA2.pm

User avatar
magick
Site Admin
Posts: 10921
Joined: 2003-05-31T11:32:55-07:00

Re: SHA2.pm problems :(

Post by magick » 2007-09-18T15:59:39-07:00

SHA1 should work fine. The problem you report may be related to the MagickStudio/workarea folder. It has to be writable by your web server.

I-B

Re: SHA2.pm problems :(

Post by I-B » 2007-09-18T16:15:08-07:00

8) I too so has thought, but with file MagickStudio/workarea all Ok
images orderly are there loaded
example
MagickStudio/workarea/f8cfdf3245a4451695125111d1092be19d146608/MagickStudio.mpc
problems with $path/MagickStudio.mpc in MagickStudio.cgi
can be is necessary $path/$session/MagickStudio.mpc ?

User avatar
magick
Site Admin
Posts: 10921
Joined: 2003-05-31T11:32:55-07:00

Re: SHA2.pm problems :(

Post by magick » 2007-09-18T17:05:18-07:00

The session folder needs to be writable as well. Make sure the MPC files have content. Next try

identify f8cfdf3245a4451695125111d1092be19d146608/MagickStudio.mpc

and see what it reports.

I-B

Re: SHA2.pm problems :(

Post by I-B » 2007-09-18T17:43:32-07:00

I upload image -> result "STOP! No such file or directory"
OK 8)
then click button "enhance" :? hm... like works
OK 8)
then press to button "enhance" -> result "No such file or directory"
is necessary all remake, but I want to sleep...

I-B

Re: SHA2.pm problems :(

Post by I-B » 2007-09-22T17:43:22-07:00

8) cool all works
I did not yet understand in than mistake, simply I be comments line:

#setpriority("PRIO_PROCESS",$$,10); 8)

and all works and like while no problems
Ok, thanks lads 8)

P.S
ImageMagick-6.3.5-10-Q16-windows-....exe flies in basket, this flaw by you

Post Reply