Error: Unable to load dynamic library

The MagickWand interface is a new high-level C API interface to ImageMagick core methods. We discourage the use of the core methods and encourage the use of this API instead. Post MagickWand questions, bug reports, and suggestions to this forum.
Post Reply
Tavocado
Posts: 1
Joined: 2012-04-04T06:02:40-07:00
Authentication code: 8675308

Error: Unable to load dynamic library

Post by Tavocado » 2012-04-04T07:43:33-07:00

I've recently been receiving the following error and I'm unable to get the MagickWand module to load into PHP:

Code: Select all

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so' - dlopen(/usr/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so, 9): Symbol not found: _zif_magicksetimageendian\n  Referenced from: /usr/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so\n  Expected in: flat namespace\n in /usr/lib/php/extensions/no-debug-non-zts-20090626/magickwand.so in Unknown on line 0
I'm using the pre installed copy of Apache and PHP on OS X Lion. Originally PHP was version 5.3.6 when I set everything up and haven't experienced any problems until my copy of PHP upgraded to 5.3.8 (presumable through a automatic system update). I originally installed ImageMagick with Homebrew which I've tried reinstalling and I've downloaded both the source of MagickWand and PHP 5.3.8 and tried recompiling it but this hasn't fixed the problem.

The only other module I've added to PHP is mcrypt and it appears to be working fine so I'm a little stumped as to what the problem could be. Any assistance would be greatly appreciated.

*just noticed this should probably be in the "MagickWand for PHP" board classic noob move but sadly I can't delete or move the current topic

Post Reply