Image Magick with Lazarus not working after update.

The MagickWand interface is a new high-level C API interface to ImageMagick core methods. We discourage the use of the core methods and encourage the use of this API instead. Post MagickWand questions, bug reports, and suggestions to this forum.
Post Reply
Steve_
Posts: 6
Joined: 2015-10-18T08:39:23-07:00
Authentication code: 1151

Image Magick with Lazarus not working after update.

Post by Steve_ » 2018-05-26T07:22:38-07:00

Hi, I've updated Lazarus and ImageMagic after 3 years, and initially I got the runtime error:

"... CORE_RL_magick_.dll is missing from your computer."

That dll is now called CORE_RL_MagickCore_.dll.

I changed the following references in ImageMagic.pas:

CORE_RL_magick_.dll to C:\Program Files\ImageMagick-7.0.7-Q16\CORE_RL_MagickCore_.dll
CORE_RL_wand_.dll to C:\Program Files\ImageMagick-7.0.7-Q16\CORE_RL_MagickWand_.dll

This made no difference and eventually I found I had to put all 25 ImageMagick dlls in the same folder as my final exe file.

Now the program executes but there are colours missing in the images, and it hits an access violation when I load a new image.

Having to put those dlls in the exe file folder is obviously not right. In the previous installation I didn't need to pull in any dlls or make any changes.

Thanks for any help,

Steve.

snibgo
Posts: 10577
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Image Magick with Lazarus not working after update.

Post by snibgo » 2018-05-26T07:49:45-07:00

Has Lazarus been updated for ImageMagick v7? I guess your previous installation was v6. If so, try de-installing IM v7 and install the current v6.
snibgo's IM pages: im.snibgo.com

Steve_
Posts: 6
Joined: 2015-10-18T08:39:23-07:00
Authentication code: 1151

Re: Image Magick with Lazarus not working after update.

Post by Steve_ » 2018-05-26T13:40:05-07:00

Thanks snibgo,

I've replaced IM v7 with v6.9.9. The images are rendering properly now, but I still have to put those 25 IM dlls in the same folder as my project exe file. That can't be right surely?

snibgo
Posts: 10577
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Image Magick with Lazarus not working after update.

Post by snibgo » 2018-05-26T13:58:56-07:00

I don't know how Pascal or Lazarus interact with IM.

When I write a C or CPP program that calls IM functions, I need to move the compiled binary (.exe) file to the IM installation, or it complains it can't find DLLs. I expect symbolic links could be used instead of physically copying files. This is with Windows 8.1 and Cygwin. I don't know how other environments work.
snibgo's IM pages: im.snibgo.com

Steve_
Posts: 6
Joined: 2015-10-18T08:39:23-07:00
Authentication code: 1151

Re: Image Magick with Lazarus not working after update.

Post by Steve_ » 2018-05-27T06:46:26-07:00

Well my main concern was about having to put all those dlls into the distribution. It's strange that in the previous version they were somehow incorporated into the project exe file, although I hadn't tested the exe away from the project folder.

Thanks for your help snibgo!

Post Reply