WinXP PerlMagick Install

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
pbrunson
Posts: 2
Joined: 2012-09-28T10:30:19-07:00
Authentication code: 67789

WinXP PerlMagick Install

Post by pbrunson » 2012-09-28T11:14:39-07:00

Howdy,

I have Active Perl 5.16.1 and Image Magick 6.7.9-Q16 installed and they are both working.

Now I am trying to install Perl Magick without luck

the ppd file gives me this error " ppm install failed: The PPD does not provide code to install for this platform "
I tried the steps on the perlmagick site, but I am having issues finding all the files that are required.

Does anyone have any suggestions to get this installed?

I am not running this from/for a web server.
I want to generate an image that has weather information on it.

-Phil

jta2010
Posts: 6
Joined: 2012-08-14T15:56:50-07:00
Authentication code: 67789

Re: WinXP PerlMagick Install

Post by jta2010 » 2012-09-29T15:27:38-07:00

I have very limited & specialized experience with PerlMagick, but in our environment, we typically have to install an older version of Perl to be able to get PerlMagick.

We upgraded our Windows 2003 servers about six weeks ago. We would have liked to run Perl 5.16, but we had to run Perl 5.14.2 to be able to run PerlMagick. We loaded Perl 5.14.2 first, and then during the ImageMagick install, we could tick the option to install PerlMagick as well. Perhaps that would work for you too?

pbrunson
Posts: 2
Joined: 2012-09-28T10:30:19-07:00
Authentication code: 67789

Re: WinXP PerlMagick Install

Post by pbrunson » 2012-10-04T07:57:20-07:00

Do you or anyone know where I can download 5.14.2? I looked around and found 5.14.4. I uninstalled both perl and imagemagick and followed the steps you outlined and it did not work either.

Thank you for the assistance,
Phil

Post Reply