PerlMagick for ActivePerl 5.14 option?

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
martin
Posts: 1
Joined: 2012-12-05T14:52:18-07:00
Authentication code: 6789

PerlMagick for ActivePerl 5.14 option?

Post by martin » 2012-12-05T15:16:19-07:00

This is for WinXP platform.

The ImageMagick installer only gives the option to install PerlMagick for ActiveState Perl 5.16.1. Older versions cause the installer to fail silently. I have updated Perl to 5.16.1, and everything is working fine, but now I want to convert my script to .EXE. I was using perl2exe, but this only supports up to 5.14. I have tried installing PAR::Packer, but I keep running into things that are missing because they only exist up to Perl 5.14, so the CPAN installer script fails. And PAR::Packer doesn't show up in ActiveState's PPM.

Is there a way to use the latest ImageMagick, but with PerlMagick that will use 5.14, so that I can use perl2exe? Or is there something far more obvious that I'm missing?

Thanks in advance for any pointers.

vassapup
Posts: 1
Joined: 2013-03-23T01:16:38-07:00
Authentication code: 6789

Re: PerlMagick for ActivePerl 5.14 option?

Post by vassapup » 2013-03-23T01:25:15-07:00

I've the same problem and found a solution:
ppm install http://www.bribes.org/perl/ppm/Image-Magick_.ppd (QD=8 Version 6.8.3)
ppm install http://www.bribes.org/perl/ppm/Image-Magick.ppd (QD=16 Version 6.8.3)

Post Reply