Cannot get PerlMagick to work on IIS7.5 + ActivePerl

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
fpotvin
Posts: 2
Joined: 2013-05-09T11:07:38-07:00
Authentication code: 6789

Cannot get PerlMagick to work on IIS7.5 + ActivePerl

Post by fpotvin » 2013-05-09T11:20:30-07:00

Greetings Image Magickers,

I'm having various issues with PerlMagick on the site I'm trying to run at the moment.
The problem I have right now is that ImageMagick run fine from the command line but when I execute this line

Code: Select all

my $img = Image::Magick->new();
print $img->read("test.jpg");
I get this

Code: Select all

Exception 420: NoDecodeDelegateForThisImageFormat `edecp/tropheequebec.com/img//300px-PNG_transparency_demonstration_2.png' @ error/constitute.c/ReadImage/550  
What I tried
Uninstall the PerlPackage, PerlMagick, ImageMagick and try other versions. I tried 9 different versions and they all gave me different problems.
Use ImageMagick from the command line. It work perfectly well there's not even a single problem. I can get all images details and convert to any format.
I checked to make sure all the delegates were there and yes, they are.
I've google and tried tons of twists for over 7 hours and nothing.

My setup
IIS 7.5
Perl 5.16.2 via ActivePerl
ImageMagick ImageMagick-6.8.3-0-Q8-x86-dll (cause recents versions won't even load)

Anybody has any recommendation.
That would be very very much appreciated.

Post Reply