Dissolve works with cmd-line, but not via PerlMagick???

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Post Reply
User avatar
magick
Site Admin
Posts: 11160
Joined: 2003-05-31T11:32:55-07:00

Post by magick »

The only solution we can offer is to upgrade your ImageMagick release. We believe Debian has a more recent release of ImageMagick in the unstable branch.

mateusmgm

Post by mateusmgm »

I have instaled the PerlMagick-6.24 version, and not run my perl code.
The image returned is equal of the original image.

$result = $image->Composite(compose=>'Dissolve', gravity=>'Center', image=>$comp, opacity=>50);
die $result if $result;

I am used
system ("/usr/bin/composite -dissolve ....")
It is poor.

Please help-me !!!

mateusmgm

Re: using Dissolve with opacity in Perl Magick, bug workarou

Post by mateusmgm »

versatilia wrote:
magick wrote:The only solution we can offer is to upgrade your ImageMagick release. We believe Debian has a more recent release of ImageMagick in the unstable branch.


I'm using IM 6.2.5 on Fedora and had this same problem.

I found out that it's a "bug" with the opacity value - it takes the lowest 16 bits of the value and uses that, where 0 = transparent and 65535 = opaque.

Try this:

$img1->Composite( image=>$img2, compose=>'Dissolve', opacity=>16000 );if course if it then gets fixed all my code will break :(


Hey versatilia, now i obtain sucess in my code.

I my souce code now is:

Code: Select all

my $opacity_fake = 50;
$img1->Composite(image=>$img2, compose=>'Dissolve',opacity=>655.35*$opacity_fake);
Correcting the possible bug!

Thanks !!! :D

Post Reply