Problems with ImageMagickObject

ImageMagickObject is a Windows COM+ interface to ImageMagick. COM+, Visual Basic, and Delphi users should post to this discussion group.
Post Reply
Shakin
Posts: 8
Joined: 2012-04-09T02:49:35-07:00
Authentication code: 8675308

Problems with ImageMagickObject

Post by Shakin » 2012-04-09T03:58:16-07:00

Hi, All

I can not register ImageMagickObject.dll either during installation process with corrisponding box set or with regsvr32.exe. In the later case I get a message about impossibility to load the module, even if I give the full path in the command line. In the former case I get "C:\Program Files\ImageMagick-6.7.6-Q16\ImageMagickObject" directory only with "test" subdirectory and "ReadMe.txt" file. The ImageMagickObject.dll file is in "C:\Program Files\ImageMagick-6.7.6-Q16" directory and I can open it with Object Browser and see its contents. But any script that uses it (in fact the SimpleTest.vbs) gives an error attempting to create the object (Set img = CreateObject("ImageMagickObject.MagickImage.1")).
So, does anybody know what is wrong or how to fix it?

Thanks in advance!

Werty
Posts: 58
Joined: 2010-08-06T05:37:36-07:00
Authentication code: 8675308

Re: Problems with ImageMagickObject

Post by Werty » 2012-04-09T21:21:27-07:00

Try placing the ImageMagickObject.dll in your windows/system32 folder and then regsrv it.
Windows 7 user

Shakin
Posts: 8
Joined: 2012-04-09T02:49:35-07:00
Authentication code: 8675308

Re: Problems with ImageMagickObject

Post by Shakin » 2012-04-10T00:04:39-07:00

Werty wrote:Try placing the ImageMagickObject.dll in your windows/system32 folder and then regsrv it.
I've alredy done it. The result is same.
I can see its contents perfectly with Object Brouser but I can't register it. Is not this strange? Has not anyone else met the same problem?

KarelmG
Posts: 2
Joined: 2012-04-21T16:15:38-07:00
Authentication code: 13

Re: Problems with ImageMagickObject

Post by KarelmG » 2012-04-21T16:19:32-07:00

Hi, I am experiencing the same thing, and did a quick test with Autoit...

The error seems to be due to a missing DLL file: IM_MOD_RL_aai_.dll

This error causes COM to fail. Anywhere I can download this DLL?

KarelmG
Posts: 2
Joined: 2012-04-21T16:15:38-07:00
Authentication code: 13

Re: Problems with ImageMagickObject

Post by KarelmG » 2012-04-21T16:41:16-07:00

OK... the required dlls are here: C:\Program Files (x86)\ImageMagick-6.7.6-Q16\modules. Putting them in the same directory, rereg and still no success.

My Machine :Windows 7 64, using ImageMagick Q16 latest win x86 build.

Dependency walker finds 2 errors:

ieshims.dll not found
Mismatching processor architecture, My system files are x64 and the IM dlls are x86.

Is there a problem with the 32 bit version on a 32bit processor? It seems to be a linking issue for x64...
Can somebody with more experience than myself have a look please?

fortine
Posts: 1
Joined: 2013-03-01T11:42:19-07:00
Authentication code: 6789

Re: Problems with ImageMagickObject

Post by fortine » 2013-03-01T11:44:11-07:00

Please download the x64 version for Windows 7 x64

http://www.imagemagick.org/script/binar ... hp#windows

Nems
Posts: 2
Joined: 2015-06-04T01:45:56-07:00
Authentication code: 6789

Re: Problems with ImageMagickObject

Post by Nems » 2015-06-04T02:02:49-07:00

Does the X64 resolved the problem?
I'm in the same situation..

Nems.

Post Reply