Linux standalone compare utility

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
vinayzz
Posts: 9
Joined: 2018-10-10T02:23:01-07:00
Authentication code: 1152

Linux standalone compare utility

Post by vinayzz » 2018-11-02T06:19:00-07:00

Hi,

I am looking for leads where I could use just the compare module with usual set of format support on linux.
The catch is that I do not want to install IM on all systems where I want to compare images. I want a bundle which can be just plug and play for linux machines.

I could do this on windows with the current downloadable exe's.

User avatar
dlemstra
Posts: 1567
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: Linux standalone compare utility

Post by dlemstra » 2018-11-05T10:47:05-07:00

You could create a static build of ImageMagick so you can deploy it easily on a Linux system.
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

vinayzz
Posts: 9
Joined: 2018-10-10T02:23:01-07:00
Authentication code: 1152

Re: Linux standalone compare utility

Post by vinayzz » 2018-11-19T03:50:58-07:00

But I do not want the installation in any case. Just the executable is all we need.
Adding a installation step will be an overhead.

B4adle7
Posts: 11
Joined: 2018-06-10T10:25:40-07:00
Authentication code: 1152

Re: Linux standalone compare utility

Post by B4adle7 » 2018-12-11T22:46:30-07:00

This would be extremely useful.
Is it possible?

User avatar
magick
Site Admin
Posts: 11043
Joined: 2003-05-31T11:32:55-07:00

Re: Linux standalone compare utility

Post by magick » 2018-12-12T04:14:27-07:00

Try building with these configure script options:

Code: Select all

./configure --disable-shared --enable-zero-configuration
That will build a static release that does not require any external configuration files. No installation is required.

Post Reply