ImageMagick 7.0.8-62 Q16 installs older FFMpeg 3.4

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
JimMcKeeth
Posts: 3
Joined: 2019-09-05T13:21:01-07:00
Authentication code: 1152

ImageMagick 7.0.8-62 Q16 installs older FFMpeg 3.4

Post by JimMcKeeth » 2019-09-05T13:30:37-07:00

I previously had FFmpeg 4.2 installed on my Windows computer. I installed ImageMagick 7.0.8-62 Q16 and it includes FFmpeg 3.4, which is older and doesn't support palettegen correctly. Unfortunately ImageMagick got ahead of FFmpeg on the path and I spent way too much time trying to figure out why palettegen stopped working.

Suggested Resolutions:
  1. Check to see if FFmpeg is installed before installing an older version
  2. Update the installer to include the latest version of FFmpeg
  3. If ImageMagick needs the older version of FFmpeg then put it in a sub-directory that isn't on the path
Thanks!

JimMcKeeth
Posts: 3
Joined: 2019-09-05T13:21:01-07:00
Authentication code: 1152

Re: ImageMagick 7.0.8-62 Q16 installs older FFMpeg 3.4

Post by JimMcKeeth » 2019-09-05T13:37:23-07:00

I realize FFmpeg is optional during the install, but it is selected by default. I just rechecked this with version 7.0.8-63 Q16 x64 2019-08-31 and the behavior is the same.

JimMcKeeth
Posts: 3
Joined: 2019-09-05T13:21:01-07:00
Authentication code: 1152

Re: ImageMagick 7.0.8-62 Q16 installs older FFMpeg 3.4

Post by JimMcKeeth » 2019-09-05T16:01:40-07:00


User avatar
magick
Site Admin
Posts: 11070
Joined: 2003-05-31T11:32:55-07:00

Re: ImageMagick 7.0.8-62 Q16 installs older FFMpeg 3.4

Post by magick » 2019-09-08T05:45:29-07:00

Thanks for the problem report. We can reproduce it and have a patch in the current release of ImageMagick, 7.0.8-64.

Post Reply