`identify' Problems

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Andriy

`identify' Problems

Post by Andriy » 2007-02-05T11:29:32-07:00

Hi,
I've got two same set of imagemagick(6.2.9 08/22/06) and gs(Ghostscript 7.07 (2003-05-17)) on two different servers(first FreeBSD, second Debian GNU Linux) for the same pdf identify gives:
FreeBSD(right result):
Type: ColorSeparation
Linux(false):
Type: Grayscale
How I can fix this problem?

User avatar
magick
Site Admin
Posts: 11077
Joined: 2003-05-31T11:32:55-07:00

Re: `identify' Problems

Post by magick » 2007-02-05T12:29:36-07:00

Check delegates.xml and see if the device differs for the ps-color tag. Let us know which device works and which one fails.

Andriy

Re: `identify' Problems

Post by Andriy » 2007-02-06T00:45:34-07:00

Here is

Code: Select all

~$ diff FreeBSD-OK-delegates.xml Linux-BAD-delegates.xml

78c78
<   <delegate decode="ps:alpha" stealth="True" command='"gs" -q -dBATCH -dSAFER -dMaxBitmap=500000000 -dNOPAUSE -dAlignToPixels=0 -dEPSCrop "-sDEVICE=pngalpha" -dTextAlphaBits=%u -dGraphicsAlphaBits=%u "-g%s" "-r%s" %s "-sOutputFile=%s" "-f%s" "-f%s"' />
---
>   <delegate decode="ps:alpha" stealth="True" command='"gs" -q -dBATCH -dSAFER -dMaxBitmap=500000000 -dNOPAUSE -dAlignToPixels=0 -dEPSCrop "-sDEVICE=pnmraw" -dTextAlphaBits=%u -dGraphicsAlphaBits=%u "-g%s" "-r%s" %s "-sOutputFile=%s" "-f%s" "-f%s"' />
81c81
<   <delegate decode="ps:mono" stealth="True" command='"gs" -q -dBATCH -dSAFER -dMaxBitmap=500000000 -dNOPAUSE -dAlignToPixels=0 -dEPSCrop "-sDEVICE=pbmraw" -dTextAlphaBits=%u -dGraphicsAlphaBits=%u "-g%s" "-r%s" %s "-sOutputFile=%s" "-f%s" "-f%s"' />
---
>   <delegate decode="ps:mono" stealth="True" command='"gs" -q -dBATCH -dSAFER -dMaxBitmap=500000000 -dNOPAUSE -dAlignToPixels=0 -dEPSCrop "-sDEVICE=pnmraw" -dTextAlphaBits=%u -dGraphicsAlphaBits=%u "-g%s" "-r%s" %s "-sOutputFile=%s" "-f%s" "-f%s"' />
112,113c112
<   <delegate decode="rgba" encode="rle" mode="encode" command='"modify" -flip -size %wx%h "rgba:%i"
<     "rawtorle" -w %w -h %h -n 4 -o "%o" "%i"' />
---
>   <delegate decode="rgba" encode="rle" mode="encode" command='"rawtorle" -o "%o" -v "%i"' />

Andriy

Re: `identify' Problems

Post by Andriy » 2007-02-09T02:17:36-07:00

Any ideas?

User avatar
magick
Site Admin
Posts: 11077
Joined: 2003-05-31T11:32:55-07:00

Re: `identify' Problems

Post by magick » 2007-02-09T08:32:09-07:00

One system uses the pngalpha device and the other pnmraw. You can try switching the devices and see if that makes a difference. So far it appears that the problem is within Ghostscript so selecting a different device may help. We're using Ghostscript 8.54 and cannot reproduce the problem you are having.

Post Reply