texteffect.sh not working in my server

A plethora of command-line scripts that perform geometric transforms, blurs, sharpens, edging, noise removal, and color manipulations.
chanchelkumar
Posts: 9
Joined: 2012-04-03T21:32:50-07:00
Authentication code: 8675308

Re: texteffect.sh not working in my server

Post by chanchelkumar » 2012-04-05T21:20:58-07:00

this is the page where wave function works..
http://ijerseys.com.temppublish.com/ck_ ... lararc.php

u can see the IM version is..
ImageMagick 6.2.8 12/13/11 Q16

Is it the issue with IM old version used in my server..
I asked my ISP to upgrade it to ImageMagick 6.6.5-10 hope this version works..

User avatar
fmw42
Posts: 25400
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: texteffect.sh not working in my server

Post by fmw42 » 2012-04-05T21:25:11-07:00

If the -wave works on that version 6.2.8, then the script should work. Please follow my suggestions on the previous post.

I do not think you set up the script properly and it is not seeing IM convert.

Please follow my guidelines and try the script again.

I do not think you need to upgrade your version of IM. It won't hurt, but you will still have the same problem with the script unless you follow my guidelines for using it with PHP.


_____________________________________
Why does your link show this error?

Notice: Undefined index: text in /vservers/ijersey1/htdocs/ck_testimage/circulararc.php on line 9

chanchelkumar
Posts: 9
Joined: 2012-04-03T21:32:50-07:00
Authentication code: 8675308

Re: texteffect.sh not working in my server

Post by chanchelkumar » 2012-04-05T21:47:11-07:00

thanks..
_____________________________________
Why does your link show this error?

Notice: Undefined index: text in /vservers/ijersey1/htdocs/ck_testimage/circulararc.php on line 9
it's because the page missing with a text variable...
but the script was working perfectly before my server update...

and i want circular arch and vertical arch... is it work with IM 6.2.8 ?

Bonzo
Posts: 2971
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: texteffect.sh not working in my server

Post by Bonzo » 2012-04-06T01:03:10-07:00

It will work with 6.2.8 as fmw42 says: "The arc effect requires IM 6.3.5-5"

Your code works for me ( 6.4.8 ) no error about a missing variable so it MUST be something wrong with your setup. Talk to your host; find a friend who has a website and get them to try it, upload the code again to make sure you have not changed something by accident.

User avatar
fmw42
Posts: 25400
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: texteffect.sh not working in my server

Post by fmw42 » 2012-04-06T10:04:16-07:00

If the -wave works on that version 6.2.8, then the script should work.

Please follow my suggestions on the earlier post. (or from my home page or from viewtopic.php?f=4&t=9631#p53156)

I do not think you set up the script properly and it is not seeing IM convert.

Please follow my guidelines and try the script again.

I do not think you need to upgrade your version of IM. It won't hurt, but you will still have the same problem with the script unless you follow my guidelines for using it with PHP.

User avatar
fmw42
Posts: 25400
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: texteffect.sh not working in my server

Post by fmw42 » 2012-04-24T21:43:34-07:00

For those following this topic. The texteffect script was created with IM v6.3.5 and will not run on IM 6.2.8 as is due to the use fx calculations that need to be ported to bc calculations in order for the script to work. Apparently the fx calculations do not work correctly on such an old version of IM as 6.2.8.

Post Reply