Lupe script from Fred's ImageMagick Scripts

A plethora of command-line scripts that perform geometric transforms, blurs, sharpens, edging, noise removal, and color manipulations.
Post Reply
Nicolas P. Rougier
Posts: 5
Joined: 2012-07-05T11:19:51-07:00
Authentication code: 13

Lupe script from Fred's ImageMagick Scripts

Post by Nicolas P. Rougier » 2012-07-05T11:27:38-07:00

I've tried to use the lupe script from Fred's ImageMagick scripts but it does not seem to work. It seems to be related to the multiply composition (see image below).

scripts: http://www.fmwconcepts.com/imagemagick/lupe/index.php
ImageMagick version: LIB_VERSION_NUMBER 6,7,7,6
os : darwin11.4.0
command: lupe -m 2 lena.png lena-lupe.png

Does anyone get the same problem ?

Nicolas

Image

User avatar
fmw42
Posts: 25392
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Lupe script from Fred's ImageMagick Scripts

Post by fmw42 » 2012-07-05T12:51:26-07:00

Nicolas,

I can confirm the problem. IM has made quite a few changes to colorspaces (and changed gray to linear) and I am still catching up with adjusting my scripts. I will see if I can find where the problem is and fix it or report a bug. Please note that some of my script, even after fixing, may still not work correctly between IM 6.7.5.5 and IM 6.7.8.1 due to various changes that progressed during that time. So I cannot cover all bases. So I would suggest that if a script fails, try upgrading to the latest release. However, it may take me a while to get all the scripts adjusted for the changes, so if any one finds a problem such as this, bring it to my attention and I will try to fix it next if possible or report a bug if not.

Sorry I have to run out for a while.

Nicolas P. Rougier
Posts: 5
Joined: 2012-07-05T11:19:51-07:00
Authentication code: 13

Re: Lupe script from Fred's ImageMagick Scripts

Post by Nicolas P. Rougier » 2012-07-05T13:26:35-07:00

Thanks for the quick reaction !

As a temportary fix, I will install a previous version of imagemagick and wait for your upgrade.

By the way, thanks for all these great scripts.

Nicolas

User avatar
fmw42
Posts: 25392
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Lupe script from Fred's ImageMagick Scripts

Post by fmw42 » 2012-07-05T15:20:05-07:00

I have fixed the lupe script. It had not been working for a long time due to some dumb errors on my part. I believe it should now work for most versions of IM.


Fred

Nicolas P. Rougier
Posts: 5
Joined: 2012-07-05T11:19:51-07:00
Authentication code: 13

Re: Lupe script from Fred's ImageMagick Scripts

Post by Nicolas P. Rougier » 2012-07-05T22:50:45-07:00

Thanks a lot ! Works like a charm.

Nicolas

Nicolas P. Rougier
Posts: 5
Joined: 2012-07-05T11:19:51-07:00
Authentication code: 13

Re: Lupe script from Fred's ImageMagick Scripts

Post by Nicolas P. Rougier » 2012-07-06T00:02:50-07:00

You may have left some debug code in the script (creation of .gif images).

Nicolas

User avatar
fmw42
Posts: 25392
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Lupe script from Fred's ImageMagick Scripts

Post by fmw42 » 2012-07-06T09:32:01-07:00

Nicolas P. Rougier wrote:You may have left some debug code in the script (creation of .gif images).

Nicolas

Thanks for notifying me. I have removed them.

Fred

Post Reply