Existing Photoshop path is not recognized

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
simon.h
Posts: 3
Joined: 2018-02-26T02:08:28-07:00
Authentication code: 1152

Existing Photoshop path is not recognized

Post by simon.h » 2018-10-10T03:42:54-07:00

Hi, I'm facing a strange issue related to Photoshop paths. For some tif files ImageMagick throws an error when I try to use them with the -clip-path option. The Photoshop paths are copied from a jpg file with exiftool. I already created a topic in the exiftool forum where the whole use case is described:

http://u88.n24.queensu.ca/exiftool/foru ... 566.0.html

You can also find a zip archive in the attachment of the initial comment there, containing some example files. The related metadata tags seem to be okay so far and Photoshop is not complaining about the paths, thats why I created another topic here in the ImageMagick forum.

Within the zip archive there is a source tif file ("input/src.tif") to which the Photoshop paths of a jpg file ("input/paths.jpg") are copied with exiftool. The resulting output file is "output/output.tif". When I execute the following command ImageMagick throws an error:

Code: Select all

convert "output/output.tif" -clip-path "Path 1" "output/converted.tif"
Error message:
convert: no clip path defined `output/output.tif': No such file or directory @ error/image.c/ClipImagePath/724.
However this error only occurs for the first path "Path 1". There is no problem with the other existing paths "Path 2" and "Path 3". As far as we could track down the cause of the issue it seems to be related to Adobe Lightroom Classic CC that was used to export the source tif file. A workaround would be to resave the source tif file with Photoshop ("input/src_resaved_with_photoshop.tif") and copy the Photoshop paths to that file. The resulting output file ("output/output_resaved_with_photoshop.tif") will then cause no problems for ImageMagick when "Path 1" is used. Btw there is also no error when I read the paths directly from the jpg file with ImageMagick.

Could you please have a look at the tif file "output/output.tif" to figure out why the Photoshop path "Path 1" is not recognized by ImageMagick? When I open that file in Photoshop I can see and edit the path "Path 1".

Tested software
macOS Sierra 10.12.6
Exiftool 11.12
ImageMagick 6.8.6-10 / 6.9.9-40 / 7.0.8-12
Adobe Photoshop CC 2018
Adobe Lightroom Classic CC

Post Reply