Failed to allocate quantum_info error

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
robert86
Posts: 3
Joined: 2018-10-13T12:38:35-07:00
Authentication code: 1152

Failed to allocate quantum_info error

Post by robert86 » 2018-10-13T12:43:23-07:00

Hi,

I am using ImageMagick through Wand for Python.
I am trying to convert a relatively large PDF file, 20mb for ~400 pages.
When I do so I get the following error:

Code: Select all

 Failed to allocate quantum_info `/tmp/magick-1681pLtRzoug0UXv298' @ error/png.c/MagickPNGErrorHandler/1643
Does anybody know what's wrong ? I've tried increasing the disk policy and I have plenty of empty disk space, but nothing helps...

My policy.xml is as follows:

Code: Select all

  GNU nano 2.5.3                                                                       File: /etc/ImageMagick-6/policy.xml

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policymap [
<!ELEMENT policymap (policy)+>
<!ELEMENT policy (#PCDATA)>
<!ATTLIST policy domain (delegate|coder|filter|path|resource) #IMPLIED>
<!ATTLIST policy name CDATA #IMPLIED>
<!ATTLIST policy rights CDATA #IMPLIED>
<!ATTLIST policy pattern CDATA #IMPLIED>
<!ATTLIST policy value CDATA #IMPLIED>
]>
<!--
  Configure ImageMagick policies.

  Domains include system, delegate, coder, filter, path, or resource.

  Rights include none, read, write, and execute.  Use | to combine them,
  for example: "read | write" to permit read from, or write to, a path.

  Use a glob expression as a pattern.

  Suppose we do not want users to process MPEG video images:

    <policy domain="delegate" rights="none" pattern="mpeg:decode" />

  Here we do not want users reading images from HTTP:

    <policy domain="coder" rights="none" pattern="HTTP" />

  Lets prevent users from executing any image filters:

    <policy domain="filter" rights="none" pattern="*" />

  The /repository file system is restricted to read only.  We use a glob
  expression to match all paths that start with /repository:

    <policy domain="path" rights="read" pattern="/repository/*" />

  Any large image is cached to disk rather than memory:

    <policy domain="resource" name="area" value="1GB"/>

  Define arguments for the memory, map, area, and disk resources with
  SI prefixes (.e.g 100MB).  In addition, resource policies are maximums for
  each instance of ImageMagick (e.g. policy memory limit 1GB, -limit 2GB
  exceeds policy maximum so memory limit is 1GB).
-->
<policymap>
  <policy domain="resource" name="temporary-path" value="/tmp"/>
  <policy domain="resource" name="memory" value="2GiB"/>
  <policy domain="resource" name="map" value="4GiB"/>
  <policy domain="resource" name="area" value="100MP"/>
  <policy domain="resource" name="disk" value="4GiB"/>
  <policy domain="resource" name="file" value="768"/>
  <policy domain="resource" name="thread" value="4"/>
  <!-- <policy domain="resource" name="throttle" value="0"/> -->
  <!-- <policy domain="resource" name="time" value="3600"/> -->
  <!-- <policy domain="system" name="precision" value="6"/> -->
  <policy domain="cache" name="shared-secret" value="passphrase"/>
  <policy domain="coder" rights="none" pattern="EPHEMERAL" />
  <policy domain="coder" rights="none" pattern="URL" />
  <policy domain="coder" rights="none" pattern="HTTPS" />
  <!-- <policy domain="coder" rights="none" pattern="MVG" /> -->
  <policy domain="coder" rights="none" pattern="MSL" />
  <policy domain="coder" rights="none" pattern="TEXT" />
  <policy domain="coder" rights="none" pattern="SHOW" />
  <policy domain="coder" rights="none" pattern="WIN" />
  <policy domain="coder" rights="none" pattern="PLT" />
  <policy domain="path" rights="none" pattern="@*" />
  <!-- disable ghostscript format types -->
  <policy domain="coder" rights="none" pattern="PS" />
  <policy domain="coder" rights="none" pattern="EPS" />
  <policy domain="coder" rights="read|write" pattern="PDF" />
  <policy domain="coder" rights="none" pattern="XPS" />
  <policy domain="coder" rights="read|write" pattern="LABEL" />
</policymap>

snibgo
Posts: 10958
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Failed to allocate quantum_info error

Post by snibgo » 2018-10-13T13:07:08-07:00

What version of IM?

"Failed to allocate" probably means you ran out of memory. Your policy.xml limits the memory and disk usage to 4 GB, which isn't much. How large are your PDF pages, in pixels?
snibgo's IM pages: im.snibgo.com

robert86
Posts: 3
Joined: 2018-10-13T12:38:35-07:00
Authentication code: 1152

Re: Failed to allocate quantum_info error

Post by robert86 » 2018-10-13T13:21:04-07:00

PDF page size in pixels is 2500x3500
I've just tried again after increasing disk usage to 16GiB without much success.
I only have 16GB RAM.

User avatar
fmw42
Posts: 24134
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Failed to allocate quantum_info error

Post by fmw42 » 2018-10-13T13:36:53-07:00

What about the width and height limits in the policy.xml? Where is the policy.xml file that you are changing? See https://imagemagick.org/script/resources.php for the potential locations.

If you are on a shared server, the hosting provider has the main policy.xml file limitations set. You can only make them more restricted and not less.

snibgo
Posts: 10958
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Failed to allocate quantum_info error

Post by snibgo » 2018-10-13T14:04:04-07:00

What version of IM? Assuming v6 Q16 integer, you need 8 bytes per pixel. 400 pages needs 28 GB.

IM will store pixels on disk when there isn't enough memory, but you might have problems before it gets that far.
snibgo's IM pages: im.snibgo.com

robert86
Posts: 3
Joined: 2018-10-13T12:38:35-07:00
Authentication code: 1152

Re: Failed to allocate quantum_info error

Post by robert86 » 2018-10-14T01:09:47-07:00

version is 6.9.10. The server is my own. I've increased disk & memory space (added a swap partition) in the policy and it seems to have done the trick so far...
thanks!

Post Reply