Can't install Perlmagic on Windows

PerlMagick is an object-oriented Perl interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning PerlMagick.
Locked
User avatar
magick
Site Admin
Posts: 11254
Joined: 2003-05-31T11:32:55-07:00

Post by magick »

The simplest solution is to download and install either the dynamic ImageMagick Q16 or Q8 Windows distribution and install. Be sure to check the box in the installer that tells it to install PerlMagick.

User avatar
rmabry
Posts: 148
Joined: 2004-04-13T11:25:27-07:00

Post by rmabry »

magick wrote: The simplest solution is to download and install either the dynamic ImageMagick Q16 or Q8 Windows distribution and install. Be sure to check the box in the installer that tells it to install PerlMagick.


For those of us who compile ImageMagick on Windows from sources, this "simplest solution" won't do. As far as my naive attempts to make PerlMagick work, the installation process is still a time-consuming mess. For those who might benefit, I'll try to state what finally worked for me below. I do hope I don't have to repeat these steps on my next installation (or if so, I hope I remember to look here) ...

1. As texmex noted:
textmex wrote: Attempting to execute the command perl Makefile.nt I recieve the following errors.

Code: Select all

Note (probably harmless): No library found for -lCORE_RL_magic_.lib 
(snip)


The problem with the first missing file is that the default configuration for most of us is not the Release, but the Debug. The PerlMagick installation wants the Release (RL) only, it seems, so that should be fixed. Can't it look for either?

Okay, so I recompiled the lot as Release.

2. The next missing file:
Note (probably harmless): No library found for oldnames.lib


which I found in

G:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\lib

Adding the above path to the LIB environmental variable (hoping it would lead to finding more missing files) improved things so that next I needed to address was

3. the next missing file
Note (probably harmless): No library found for user32.lib


That one was here, and I taked it on to LIB:

G:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\PlatformSDK\Lib

That got me through the first part, so now the command

perl makefile.nt

worked.

4. The next task was to run

nmake install

That failed because nmake was not in my Path. I found it and fixed that.

5. But then the nmake install failed because it not find the file

mspdb71.dll

A helpful poster somewhere on the web snottily told some neophyte that this problem occurs because the naif "forgot to" execute

vsvars32.bat

Tsk, silly kid, forgetting to do such a thing. Of course that needs its own change to Path. I forget where I found it, but that part is easy.

****

Well, at last the nmake ran and I tried out the demo scripts and things for now seem to be working.

All this wrecked my morning. Similar travails have surely wasted countless hours of who-knows-how-many others. I hope such things can be fixed soon.

I'm venting, of course, realizing full well that the IM group has limited time and too many fires. But so do the rest of us.

Anyway, I'll try to post something nice some time to make up for this rant.

Rick

Locked