Search found 29 matches

by dncpax
2016-05-10T11:33:13-07:00
Forum: Fred's Scripts
Topic: error with autotone under cygwin unable to open pixel cache
Replies: 36
Views: 48022

Re: error with autotone under cygwin unable to open pixel cache

it's ok really. I can run that one script in a vm. The other scripts run fine.
by dncpax
2016-05-10T09:11:10-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

Re: autotone - expected results

Fred, that's relevant, and useful to correct in-image differences. I see also a good use-case for these scripts, because sometimes people who produce the aerials join images from different dates, resulting in 2 very different halves inside the one image. For the case explained above the trick is get...
by dncpax
2016-05-10T08:14:39-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

Re: autotone - expected results

Yes that's true, aereal imagery capture everything. That's covered best by some of the methods, for instance 'color grid' or 2nd surface color target, though I prefer the polynomials. gain-and-bias could be better like you say. I may be miss-understanding, but can it be applied like this? I mean, I ...
by dncpax
2016-05-10T08:06:57-07:00
Forum: Fred's Scripts
Topic: error with autotone under cygwin unable to open pixel cache
Replies: 36
Views: 48022

Re: error with autotone under cygwin unable to open pixel cache

ok, so I got to run autotone and keep an eye on tmpRGB.cache desapearing act... I added 'read -p "Press [Enter] key to continue..."' to a bunch of places so I could see it. The tmpRGB.cache is deleted when we reach the last pause in the following output. It seems to me it happens on "convert './AUTO...
by dncpax
2016-05-10T06:54:43-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

Re: autotone - expected results

Hi there again. Looking at the results of gainbias and histmatch, they are sometimes good sometimes not so good, as would be expected, since we are trying to get a set of images to look as much as possible like another reference image. I think this is another kind of problem. How to get a set of ima...
by dncpax
2016-05-07T11:45:06-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

Re: autotone - expected results

Fantastic!! That did it. What a relief... starting to think I was jinxed...
by dncpax
2016-05-07T10:10:29-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

Re: autotone - expected results

@snibgo I'm sorry to be here again with errors... maybe it's me, but I get this error at calcGainBias: identify.exe: unable to parse expression `igb2_mn_R' @ error/fx.c/FxGetSymbol/1848. You can see the meanSdTr runs fine. It's the calcGainBias that errors out... Using ImageMagick 6.9.3-10 Q16 x64 2...
by dncpax
2016-05-06T10:31:22-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

Re: autotone - expected results

Ok, makes sense.

Having several of these images with different brightness, histograms, etc., how would you try to make them all more similar to each other. I was hoping that one of your auto* scripts could do this, since you analyze the histograms and make adjustments from there.
by dncpax
2016-05-06T06:43:59-07:00
Forum: Fred's Scripts
Topic: autotone - expected results
Replies: 13
Views: 22300

autotone - expected results

Hi there. I am surprised by the results of running autotone on an image. Could anyone confirm this is what's expected? Thanks Original: https://edia1-my.sharepoint.com/personal/dcarreira_edia_pt/_layouts/15/guestaccess.aspx?guestaccesstoken=w9vxtWbRjl698KtP%2bl23%2fmdMjwFBeCX2McBHxPikqps%3d&docid=1f...
by dncpax
2016-05-05T08:53:02-07:00
Forum: Fred's Scripts
Topic: error with autotone under cygwin unable to open pixel cache
Replies: 36
Views: 48022

Re: error with autotone under cygwin unable to open pixel cache

Hi Fred. Tried the new script with same results, using a small image: $ identify ./Product151Clip.tif ./Product151Clip.tif TIFF 2034x1224 2034x1224+0+0 8-bit sRGB 847KB 0.000u 0:00.003 Same thing. Note that it works in a Lubuntu VM with a small disk. I suspect something is going on with IM under win...
by dncpax
2016-05-03T14:05:37-07:00
Forum: Fred's Scripts
Topic: Scripts
Replies: 9
Views: 21793

Re: Scripts

@PandoraBox - sorry to hear about your health. Best of luck.

If anything your scripts may be usefull to anyone without win10+bash.
by dncpax
2016-05-03T11:54:02-07:00
Forum: Fred's Scripts
Topic: error with autotone under cygwin unable to open pixel cache
Replies: 36
Views: 48022

Re: error with autotone under cygwin unable to open pixel cache

yes... I've downloaded it again just now and same error. Noticed it still states "revised 4/21/2016"...
by dncpax
2016-05-03T07:54:32-07:00
Forum: Fred's Scripts
Topic: error with autotone under cygwin unable to open pixel cache
Replies: 36
Views: 48022

Re: error with autotone under cygwin unable to open pixel cache

Update: tried on another machine with same error.

I'm now running the scripts in a vbox lubuntu vm. Everything's running although a bit slowish...

Can't figure out what's wrong. But hopefully PandorasBox bat scripts will help the situation.

Thanks to all your help and patience.
by dncpax
2016-05-01T12:32:35-07:00
Forum: Fred's Scripts
Topic: error with autotone under cygwin unable to open pixel cache
Replies: 36
Views: 48022

Re: error with autotone under cygwin unable to open pixel cache

I'm going to test it on another machine tomorrow...