Upgraded and now I have issues

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Marquisk2
Posts: 4
Joined: 2013-09-09T08:50:53-07:00
Authentication code: 6789

Upgraded and now I have issues

Post by Marquisk2 » 2013-09-09T08:56:09-07:00

I had an older version of ImageMagick from 2012 under Centos 5.9 (6.2.x) and everything worked out fine with running this command:
convert -verbose /home/dev.logorally.com/htdocs/sites/default/files/private/assets/logos/bookmark1_6.svg /home/dev.logorally.com/htdocs/sites/default/files/temp/gsUZ4Zf9XSdXHydwoBQVYdn1kHARuybKMEmZwwl4IXY/5.png

I then decided to upgrade ImageMagick to 6.8.9 and tried to run the same exact command as previously but I get this error now:

sudo convert -verbose /home/dev.logorally.com/htdocs/sites/default/files/private/assets/logos/bookmark1_6.svg /home/dev.logorally.com/htdocs/sites/default/files/temp/gsUZ4Zf9XSdXHydwoBQVYdn1kHARuybKMEmZwwl4IXY/5.png
"inkscape" "/home/dev.logorally.com/htdocs/sites/default/files/private/assets/logos/bookmark1_6.svg" --export-png="/tmp/magick-22659jMAQUzlaF4Pl" --export-dpi="90,90" --export-background="rgb(100%,100%,100%)" --export-background-opacity="1" > "/tmp/magick-22659NQNqR-DOzr2N" 2>&1

(process:22659): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:22659): GLib-GObject-CRITICAL **: gtype.c:2240: initialization assertion failed, use IA__g_type_init() prior to this function

(process:22659): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
convert: memory allocation failed `/home/dev.logorally.com/htdocs/sites/default/files/private/assets/logos/bookmark1_6.svg' @ error/svg.c/ReadSVGImage/2918.
convert: no images defined `/home/dev.logorally.com/htdocs/sites/default/files/temp/gsUZ4Zf9XSdXHydwoBQVYdn1kHARuybKMEmZwwl4IXY/5.png' @ error/convert.c/ConvertImageCommand/3127.


I'm at a loss and I need this working :( Even if it's saying out of memory I tried -memory and -map. I have a dedicated web server so there should be enough ram.

snibgo
Posts: 12162
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Upgraded and now I have issues

Post by snibgo » 2013-09-09T09:01:50-07:00

It sounds like the same bug as reported here: viewtopic.php?f=3&t=23035

If so, I suggest to copy your post above to that thread.
snibgo's IM pages: im.snibgo.com

Post Reply