Build Error.. Trying to install on Centos 6.4

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
dognose
Posts: 267
Joined: 2005-03-08T22:16:37-07:00

Build Error.. Trying to install on Centos 6.4

Post by dognose » 2013-11-25T09:11:38-07:00

So, I'm trying to build and or install ImageMagick lastest on a new Centos 6.4 box

With the binary release, I get:
rpm -Uvh ImageMagick-6.8.7-7.x86_64.rpm
error: Failed dependencies:
libHalf.so.4()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
libIex.so.4()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
libIlmImf.so.4()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
libImath.so.4()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
libfftw3.so.3()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
liblqr-1.so.0()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
libltdl.so.3()(64bit) is needed by ImageMagick-6.8.7-7.x86_64
libwebp.so.4()(64bit) is needed by ImageMagick-6.8.7-7.x86_64

with rpmbuild from source, I get

RPM build errors:
File not found by glob: /root/rpmbuild/BUILDROOT/ImageMagick-6.8.7-7.x86_64/usr/lib64/libMagick++*so*

Any advice on how to build this version, or at least get it installed. Thanks.

Post Reply