Ubuntu 14.04 and ImageMagick

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
johnfl68
Posts: 33
Joined: 2012-07-09T18:31:26-07:00
Authentication code: 13

Ubuntu 14.04 and ImageMagick

Post by johnfl68 » 2015-09-12T05:35:58-07:00

Hello:

The default install of ImageMagick on Ubuntu Server 14.04 is 6.7.7-10 which works but has issues.

This version has issues with caption text being cut off in some instances. It is my understanding this has been fixed in newer versions.

Has anyone successfully installed the current version of ImageMagick 6.9.2-0 on Ubuntu Server 14.04?

Even the most recent versions of Ubuntu only go up to 6.8.9.9-5. I am trying to stay with the LTS versions of Ubuntu (Long Term Support), and the next LTS release isn't until April 2016, and it will also more than likely be behind with ImageMagick versions.

I use ImageMagick through Perl using Image::Magick - just in case that has any bearing with use issues on the newer versions.

I would like to use the most recent version, but in searching around I have found many posts from people that have had issues installing and working.
Also, there seem to be varied instructions on how to install.

If anyone has had luck with this, if there are instructions that you followed that worked, please let me know.
I would like to know a little more before I spend money on another virtual server instance to try and see if I can get loaded an working properly, before loading on production server.

Thanks for your help!

John

vpmammana
Posts: 37
Joined: 2015-12-06T14:13:46-07:00
Authentication code: 1151

Re: Ubuntu 14.04 and ImageMagick

Post by vpmammana » 2015-12-19T20:33:51-07:00

I am having problems to update IM in Ubuntu 14.something either.

I need 6.8.9, so I wonder how you installed this intermediate version?

Post Reply