Page 1 of 1

Posted: 2005-11-09T23:40:59-07:00
by anthony
It was more likely the tiff was lying to IM.

TIFF is a crazy format of old obsolete profiles and addons developed from the days before JPEG's and PNG's were invented. Avoid it if posible.

Please note that the resolution or dpi of an image is completely irrelevent to the images size. It is just a set of numbers stored with the image to tell output devices such as printers and displays how many dots (or pixels) per inch the image should be displayed at, or for vector formats like postscropt, pdf, MWF, the pixel scale to draw the image in.

You can set and or change the resolution of an image as it is being read into IM by using the -density function.

EG: convert -density 600x600 image.tif new.tif

Posted: 2005-11-12T22:30:16-07:00
by anthony
Strip profiles with -strip
Easy :)

Posted: 2005-11-13T16:31:47-07:00
by anthony
The "-strip" option will remove all the profiles from an image, including the one holding the photoshop resolution of the image. Once that profile is removed photoshop should (as per the online manual for "-density" says), understand the new density resolutions you set.

I do not know the name of the actual profile you need to strip, so I can't give you a more specific "+profile 'name'" option. Anyone out there know so we can update the manual?

Some alturnatives for profile editing include..

Code: Select all

  perl ExifTool
  winGUI ExifTool
Please let me know what you do an find, as this is an area I am not concentrating on with the examples, as profiles is less IM specific.

Posted: 2005-11-14T18:48:09-07:00
by anthony
If -strip does not work you probably have a version 5 IM, upgrade!

If you can't upgrade try +profile '*' to strip all profiles.

Posted: 2005-11-14T20:15:59-07:00
by anthony
Put -density BEFORE reading the image in.

Posted: 2005-11-15T16:49:09-07:00
by anthony
No idea about RemoveImageProfile download an try it.

Posted: 2005-11-29T17:55:36-07:00
by anthony
More like a bug of the TIFF format which has been hacked by just about every windows image program. The format should be phased out!

Posted: 2005-11-30T20:53:34-07:00
by anthony
No I mean before JPEG and PNG came about lots of programs, including photoshop and coreldraw added junk to the image format for their own purposes which were not (and probably will never be) understood by other programs. It has had every sort of compression and internal formating just tacked on, and generally it was all done without any control of features.

For a 'interchange file format' (IFF) it is horrible, and I every time I used it I have lost more hair!

It is a hack! Avoid it if you can!

Posted: 2005-12-01T20:58:37-07:00
by anthony
I haven't seen, or even know what the -unit option is for!

Set output dpi with montage command?

Posted: 2005-12-07T20:58:39-07:00
by andyroo
I've been struggling with a similar problem as to what has been described in this thread, except with the montage command. I can get convert to work fine, with the output image defined correctly as 300 dpi, but can't seem to nail it with the montage command. The -unit argument as described here isn't valid with montage, although I'm very thankful that it was mentioned in this thread! My workaround has been to use montage first, then issue the convert command separately to set the image resolution, as follows:

montage -density 300x300 infilename.eps -page 5100x3300 -tile 7x -geometry +25+10 outfilename.tif (output image here says 72 dpi)

convert -density 300x300 -units PixelsPerInch infilename.tif outfilename.png (output image here says 300 dpi, the desired result)

Any possibility of combining these into a single command line? I'm using ImageMagick-6.2.5-Q16, which I only just downloaded a couple of weeks ago.



Posted: 2005-12-07T21:07:35-07:00
by anthony
Request it and -unit can be added to montage.

However did you know convert can save images into the source image filename without problems?

No need for a temporary file if you are sure you have it working correctly.

Posted: 2005-12-08T11:45:10-07:00
by andyroo
That's good to know re: the temporary file; thanks for pointing that out.

I assume I should make such a request in the "bugs" forum (?), even though it's not really a bug in the strictest sense.



Posted: 2005-12-08T18:40:48-07:00
by anthony
Montage should understand all convert options exept those whcih are montage specific. EG -frame -convert -tile. Settings (including -geomerty) are
fine and can not be used for both purposes.

See IM examples 'montage' page.

montage with -units option

Posted: 2006-02-28T08:52:37-07:00
by andyroo

I followed up with a bug report as you suggested, waited patiently for imagemagick 6.2.6 to be released, installed it and tested the montage command and it still doesn't work. The -units option is now recognized by montage, but it doesn't seem to do anything... I posted another bug report as per the link below, but haven't received a response. Is this a bug in the software, or am I doing something wrong in the command line?

My bug report is here, with examples of what I've tried already: ... php?t=5463