Page 1 of 1

no decode delegate for this image format

Posted: 2020-02-19T04:28:46-07:00
by gumma
i have tried image magick in my linux system
i have installed and try to in my python code

example:

Code: Select all

from wand.image import Image as wi

pdf = wi(filename="/home/techstriker/Music/sample.pdf", resolution=300)
                        pdfImage = pdf.convert("jpeg")
                        i = 1
                        for img in pdfImage.sequence:
                            page = wi(image=img)
                            page.save(filename=str(i)+".jpg")
                            i=+1
but on this line its show error "wi(filename="/home/techstriker/Music/sample.pdf", resolution=300)"
wand.exceptions.MissingDelegateError: no decode delegate for this image format `' @ error/constitute.c/ReadImage/562


i also checked delegate using this command

Code: Select all

$ convert -list configure | grep -i "delegates"
DELEGATES             mpeg jpeg ps
DELEGATES             jpeg 
but still same issue

Re: no decode delegate for this image format

Posted: 2020-02-19T05:34:58-07:00
by snibgo
What version of IM?

In Python, leading spaces are significant. So when pasting Python code, please put it inside [ code ] and [ /code ] tags.

I don't know why you have two "DELEGATES" lines. Please post the complete output of "convert -list configure" and "convert -version".

Is Ghostscript installed on your computer? Does it work?

Re: no decode delegate for this image format

Posted: 2020-02-19T21:57:21-07:00
by gumma
i am using version of IM(7.0.9)

The output of "convert -list configure"

Path: /usr/local/lib/ImageMagick-7.0.9//config-Q16HDRI/configure.xml
Name Value
-------------------------------------------------------------------------------
CC gcc
CFLAGS -fopenmp -g -O2 -Wall -mtune=core2 -fexceptions -pthread -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=16
CODER_PATH /usr/local/lib/ImageMagick-7.0.9/modules-Q16HDRI/coders
CONFIGURE ./configure
CONFIGURE_PATH /usr/local/etc/ImageMagick-7/
COPYRIGHT Copyright (C) 1999-2020 ImageMagick Studio LLC
CPPFLAGS -I/usr/local/include/ImageMagick-7
CXX g++
CXXFLAGS -g -O2 -pthread
DEFS -DHAVE_CONFIG_H
DELEGATES mpeg jpeg ps
DISTCHECK_CONFIG_FLAGS --disable-deprecated --with-quantum-depth=16 --with-jemalloc=no --with-umem=no --with-autotrace=no --with-gslib=no --with-fontpath= --with-rsvg=no --with-perl=no
DOCUMENTATION_PATH /usr/local/share/doc/ImageMagick-7
EXEC-PREFIX /usr/local
EXECUTABLE_PATH /usr/local/bin
FEATURES DPC HDRI Cipher OpenMP
FILTER_PATH /usr/local/lib/ImageMagick-7.0.9/modules-Q16HDRI/filters
GIT_REVISION 16920
HOST x86_64-pc-linux-gnu
INCLUDE_PATH /usr/local/include/ImageMagick-7
LDFLAGS -L/usr/local/lib
LIB_VERSION 0x709
LIB_VERSION_NUMBER 7,0,9,24
LIBRARY_PATH /usr/local/lib/ImageMagick-7.0.9
LIBS -ljpeg -lm -lgomp
NAME ImageMagick
PCFLAGS -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=16
PREFIX /usr/local
QuantumDepth 16
RELEASE_DATE 2020-02-19
SHARE_PATH /usr/local/share/ImageMagick-7
SHAREARCH_PATH /usr/local/lib/ImageMagick-7.0.9/config-Q16HDRI
TARGET_CPU x86_64
TARGET_OS linux-gnu
TARGET_VENDOR pc
VERSION 7.0.9
WEBSITE https://imagemagick.org

Path: [built-in]

Name Value
-------------------------------------------------------------------------------
DELEGATES jpeg
FEATURES Cipher DPC HDRI OpenMP(4.5)
MAGICK_TEMPORARY_PATH /tmp
NAME ImageMagick
QuantumDepth Q16

###############
The output of convert -version
Version: ImageMagick 7.0.9-24 Q16 x86_64 2020-02-19 https://imagemagick.org
Copyright: © 1999-2020 ImageMagick Studio LLC
License: https://imagemagick.org/script/license.php
Features: Cipher DPC HDRI OpenMP(4.5)
Delegates (built-in): jpeg


yes ghostscript already installed

Re: no decode delegate for this image format

Posted: 2020-02-20T10:05:19-07:00
by fmw42
You have only minimum delegates:

Code: Select all

DELEGATES mpeg jpeg ps
So no Ghostscript (gs or gslib) and also later it says --with-gslib=no

So I suggest you reinstall from a binary so as to get all the standard delegates and make sure you have installed Ghostscript first.