Can't build ImageMagick

Post any defects you find in the released or beta versions of the ImageMagick software here. Include the ImageMagick version, OS, and any command-line required to reproduce the problem. Got a patch for a bug? Post it here.
Post Reply
lleche
Posts: 10
Joined: 2012-11-25T14:50:18-07:00
Authentication code: 6789

Can't build ImageMagick

Post by lleche » 2013-02-16T00:08:30-07:00

Still can't build ImageMagick, apparently due to graphviz changes.
Log file under MacOSX 10.8.2, build using MacPorts, graphviz version @2.30.0, Revision 2, Imagemagick version 6.8.3-0:

CCLD coders/hald.la
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
ld: library not found for -lgraph
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [coders/dot.la] Error 1
make[2]: *** Waiting for unfinished jobs....
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
clang: warning: argument unused during compilation: '-pthread'
ld: warning: directory not found for option '-L/opt/local/lib/ImageMagick-6.8.3'
make[2]: Leaving directory `/opt/local/var/macports/build/_Volumes_Data_Users_Landry_dports-dev_graphics_ImageMagick/ImageMagick/work/ImageMagick-6.8.3-0'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_Volumes_Data_Users_Landry_dports-dev_graphics_ImageMagick/ImageMagick/work/ImageMagick-6.8.3-0'
make: *** [all] Error 2
make: Leaving directory `/opt/local/var/macports/build/_Volumes_Data_Users_Landry_dports-dev_graphics_ImageMagick/ImageMagick/work/ImageMagick-6.8.3-0'
Command failed: cd "/opt/local/var/macports/build/_Volumes_Data_Users_Landry_dports-dev_graphics_ImageMagick/ImageMagick/work/ImageMagick-6.8.3-0" && /usr/bin/make -j8 -w all
Exit code: 2
Error: org.macports.build for port ImageMagick returned: command execution failed
DEBUG: Error code: CHILDSTATUS 21642 2
DEBUG: Backtrace: command execution failed
while executing
"system -nice 0 $fullcmdstring"
("eval" body line 1)
invoked from within
"eval system $notty $nice \$fullcmdstring"
invoked from within
"command_exec build"
(procedure "portbuild::build_main" line 8)
invoked from within
"$procedure $targetname"
Warning: targets not executed for ImageMagick: org.macports.activate org.macports.build org.macports.destroot org.macports.install
Please see the log file for port ImageMagick for details:
/opt/local/var/macports/logs/_Volumes_Data_Users_Landry_dports-dev_graphics_ImageMagick/ImageMagick/main.log
To report a bug, follow the instructions in the guide:
http://guide.macports.org/#project.tickets
Error: Processing of port Imagemagick failed

User avatar
magick
Site Admin
Posts: 11100
Joined: 2003-05-31T11:32:55-07:00

Re: Can't build ImageMagick

Post by magick » 2013-02-16T13:37:32-07:00

We can't help, we do not support MacPorts. Try the MacPorts developers.

User avatar
fmw42
Posts: 25765
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Can't build ImageMagick

Post by fmw42 » 2013-02-16T13:59:50-07:00

You can install all your delegates from MacPorts as I do, then install IM manually from source. See viewtopic.php?f=1&t=21502&p=88202&hilit ... rts#p88202

asahiro
Posts: 1
Joined: 2013-02-18T05:19:23-07:00
Authentication code: 6789

Re: Can't build ImageMagick

Post by asahiro » 2013-02-18T05:38:09-07:00

I don't know how to change the option '-lgraph' to '-lcgraph'.

Code: Select all

% cd /opt/local/lib
% sudo ln -s libcgraph.dylib libgraph.dylib
:(;゙゚'ω゚'):
But then, you can "build" 6.8.3 with Macports.
I cannot guarantee it works well.

Post Reply